Sign in to follow this  
Otniel Ruelas

V8 Official Thread

Recommended Posts

tjohn    0

Hi, I just installed my second V8 and I'm having the same worries. I have an Asrock gen3 pro board with a 2600k proc. The first one I installed would not tighten down right. I was only able to get so far until the screws would start turning with the nuts. I thought they were stripped so I RMA'd it. Last night I received my second and the same thing happened. The screws are preinstalled with springs in the top brackets and do not stay tightly in place. I have it installed on my board and it is tight and cooling great but the top bracket is not tightened down to hit the rubber spacers and I turned each of the nuts until the screws turned with them. Is this normal? Never had this problem with my thermalright ultra extreme.

Share this post


Link to post
Share on other sites
CM Jerry    43

Hello hawk3232,

Could you please show more detail about it? Or you can change the cooler power cable to other pins on the motherboard first~

If you still have some problems, please let us know and we will try to solve it!

thanks

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this