Sign in to follow this  
slamdunk

850W PSU Died - Twice!

Recommended Posts

slamdunk    0

Slightly annoying problem. I bought my computer 5 months ago. It included:

Coolermaster Stacker 830 Evolution Silver with Black Mesh w/o PSU Super-Hi End

850W Coolermaster Real Power Pro RS-850-EMBA 85% Eff' ATX12V V2.2 SSI EPS12V v2.91 4xPCI-E/8xSATA

The day after I built the system, the computer stopped functioning. On returning the gear it was put to a blown PSU, which also took the video card with it (768Mb Asus 8800GTX V2 PCI-E (x16).

Two weeks ago, the same problem occurred. This time, only the PSU was deemed faulty. The computer had been running perfectly for five months. I do not overclock the computer in any way. The machine failed to power up having worked fine the day before.

Suffice to say I am slightly annoyed that the same problem has occurred twice to the same component.

Does anyone know of any faults or incompatibilities with these products?

Thanks!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this