Sign in to follow this  
Paul343

CM 690

Recommended Posts

VALKYRIE    11
Hey guys

Richie from down under here

Just got this case the other day and its pretty cool.

I also had a problem with the Hard Drive cage. i had to feed the sata cables through the back of the case making the cables tight

if theres another way please let me know. HD is all SATA.

Another thing about the power supply placement. The fan of the power suppy should be facing the motherboard or should it be facing the side of the case so it sucks air from the outside thanks guys

I think the PSU powersupply must be upside down ,suking air from the outside of the case ,there are plenty of holes at the bottom of the case

Share this post


Link to post
Share on other sites
knud    128

Psu should be faced downwards and sucking the cold air in from the bottom/outside

Share this post


Link to post
Share on other sites
-=Draven=-    0
Psu should be faced downwards and sucking the cold air in from the bottom/outside

The fan on the bottom of a PSU sucks or blows air?

Share this post


Link to post
Share on other sites
LuckyNV    0
Psu should be faced downwards and sucking the cold air in from the bottom/outside

The fan on the bottom of a PSU sucks or blows air?

afaik ALL PSUs suck air into the unit and expells out the back

Share this post


Link to post
Share on other sites

I didn't see a speaker lead or speaker itself but I admit I didn't totally disassemble the case.

I'm asking because I just finished assembling a new build and it's not coming up . . . but since Asus has their 3pin mobo LED lead I can't get any (limited) debug out of that and also don't have a speaker going for me.

Figured I'd ask, is there a speaker and, if so, where's the lead/what's it look like? Thanks.

Share this post


Link to post
Share on other sites
Richie    0

cool. thats how i installed it

Fan facing the bottem and sucking air from outside the case. i guess thats one of the reasons why they included rubber legs on the case.

Cheers guys

Share this post


Link to post
Share on other sites
billyo55    0

I am in the process of my first pc build. I am having difficulty connecting the CM690 panel wires to my mobo(Asus P5N32-E SLI Plus). I connected the HDD LED, POWER SW, and RESET SW. How do you figure out what wires to plug into the the top panel of pins for the SPEAKER? Also, can you please tell me how I should go about connecting the PLED? The CM690 doesn't have the same pin configuration as the ASUS PLED. The CM690 has the wires configured +PLED,-PLED and my ASUS mobo has +PLED,SPACE,-PLED. Also, how do I connect the AC'97 and the AZALIA plugs?If you could help that would be awesome. I haven't had any luck with the CM phone reps.

Share this post


Link to post
Share on other sites
knud    128

The hdd led is indeed 2 pin fixed. The best way is to cut the connector in half and then connect it.

The AC'97 plugs go on the motherboard and there is only one way of fitting them in. (pls see the motherboard manual for the location of the audio header)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this