Sign in to follow this  
Dakon

Real Power Pro 850w cold boot issue

Recommended Posts

Lou Cifer    0

Hello everyone, new to the forums.

I bought my Real power pro 850W(RS-850-EMBA) in mid April getting ready for my build, but now I see that unfortunatly my PSU is defective.

I went to the CM homepage but could not locate where I could start the RMA proccess.

I'll be buying the last componate(CPU) for my build within the next week, and I would like to get the ball rolling on this.

Could someone stear me in the right direction, and also, I read through this thread and I may have overlooked it but what is the tunaround on the RMS proccess on this item.

Thanks.

Lou

P.S. Is it possible that my PSU is an "80PLUS", and not have the sticker?.

Share this post


Link to post
Share on other sites
Unbornchild    0

Hopefully this issue is over now.

Yesterday i bought the modular version (M850) in a local shop. It is so new it should not even be in the shops yet. :lol:

I bought it because later i will buy HD2900XT, and i read excellent reviews about the Realpower Pro 850. BUT i also am aware that HD2900XT requires the 8pin cable for overclocking. Overclocking is what i always do. :)

At first i bought in another local shop the not modular Realpower Pro 850, 20 euros cheaper than the modular version elsewhere, i did not realise the crucial difference yet. At home i saw it lacks the 8pin connectors, and is ATX2.2 compliant while i expected it to be 2.3 compliant. I returned it next day, and bought the modular version in the other shop. Happy.

Came home, inspected the contents. ATX 2.3 compliant, 8pin connectors but NO 8pin cables! Studied the reviews, the CM website and came across this forum, this thread.

Today i called Coolermaster in my country, asked the guy my questions.

Conclusion: the RS-850-ESBA i bought, is 80+ certified, as all modular versions are although they don't have the sticker on the box. When it says it is ATX2.3 compliant you're safe. He assured me that the issue in this thread is history and does not affect this model at all. No cold boot issue, no issue with any motherboard at all.

The cables should have been in the box, and he is sending them to my home today. 8)

Share this post


Link to post
Share on other sites
knud    129

Just to make it more clear:

Real Power pro standard :RS-850-EMBA had 2 versions, one without 80plus sticker and one with 80plus sticker

Real Power pro modular: RS-850-ESBA has 1 version, is 80plus, but has no sticker.

@Unbornchild, we send it tomorrow, I hope that's ok too?

Share this post


Link to post
Share on other sites
robert3892    0

I have the master cooler 850 watt standard WITHOUT the 80 plus sticker and I am having the cold boot problems. I notified my dealer in the Netherlands and he said the cold boot issue is well known and must be resolved directly with master cooler Europe support. I need my PC everyday as I work from home in the evenings. Is there anything that can be done for me?

Share this post


Link to post
Share on other sites
Geezer    0
For those who are experiencing problems, please contact our RMA dept and get an RMA number. Once we receive the new batch, we will immediately ship them to you.

Hi,

I sent my RMA request on the 29th of July. So far I haven't even received an email advising me that my request has been received. Either an auto responce or from a live body. When can I expect some kind of confirmation. For all I know my request has gone down a cyber trash can.

Thanks

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this