Sign in to follow this  
wmwooten

eXtreme Power 600W PSU won't boot

Recommended Posts

wmwooten    0

Hello, I purchased my 600W from ZipZoomFly last month 7/18, when I connected it I got power; CPU/PSU/GPU/Case fans, Hard Drives, CD/DVDs, even MB ready LED, but NO POST, no beeps, no boot evidence at all other than intermittent keyboard LED blinks (like a prePOST reboot).

Everything works with my old 350W PSU, no other differences in the system. I am on my third exchange from ZZF and they have graciously sent a brand new PSU each time. I have now spent $40 on return shipping and each PSU has done the same thing.

Is there any way I can get a pre-tested or certified replacement from you guys? I don't know if it's a bad lot or incompatibility with my hardware, but I can't spend any more $ on this problem and I am down a machine while I wait. I would even be willing to do a Credit Card preship if you have that available. Any suggestions would be greatly appreciated.

I have always sworn by Cooler Master and this is the first problem I have ever had with a CM product (14yrs in the biz), please don't let me down. Thanks

Here are my system specs for reference:

Asus P5LD2 945P, ATI X1900 AiW, iP930 retail, Corsair TWIN2X2048-5400C4, Coolermaster 713001180 PSU, WD 320GB SATA, WD 250GB PATA, LiteON DVD/RW, Teac CDRW

Share this post


Link to post
Share on other sites
wmwooten    0

Hello again, +12V lead reads 11.88V (within ATX ± specs but startlingly low, prev. PSU was 11.78V), all other line volts read at or above spec. System still will not POST even with minimal load (MB/CPU/GPU).

Once again, thanks for any help.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this