Weijing

MASTER WATT 650 WEIRD SOUND

Recommended Posts

Weijing    0
Posted (edited)

https://voca.ro/61OFsJOsDp8

This is the link for the sound

 

I am using Masterwatt 650 but it appear a weird sound which like from a fan crash around 2 seconds

and it keep happen around every 10mins.

 

Anyone is facing same issue?

is that a big issue for the power supply?

Edited by Weijing

Share this post


Link to post
Share on other sites
Mohd Noh    29

So far all of my power supply running in good condition .

8 hours ago, Niventics said:

You bought a coolmaster, what did you expect? Terrible quality!

If you facing with the quality you can return it where you bought it or you can RMA .

Share this post


Link to post
Share on other sites
Niventics    0

Im sure as a mod on their forum you'll never encounter a problem. I lost thousands of dollars on a faulty coolmaster psu and got a "sorry", so weijing if you still can I recommend you return it while you can and look for a reputable company with a good warranty plan!

Share this post


Link to post
Share on other sites
Mohd Noh    29
1 hour ago, Niventics said:

Im sure as a mod on their forum you'll never encounter a problem. I lost thousands of dollars on a faulty coolmaster psu and got a "sorry", so weijing if you still can I recommend you return it while you can and look for a reputable company with a good warranty plan!

like i mentioned above you guys can return it if you found faulty or defective units.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.