Edwin

MM830 and Portal V1.7.4 Not working

Recommended Posts

Edwin    0

I just got my Cooler Master MM830 mouse today and I downloaded the latest version of Portal (V1.7.4 at this time) to customize the setting and buttons but anytime I try to update the firmware (current is 0119 to new version is 1105 at this time) for the mouse the the firmware update window pops up but doesn't let me click "OK" or "abort" for the update. If I click on the firmware update screen it goes into an endless loading loop until I click on it again and says "FWUpdate is not responding".  After I close the program and try to open Portal again it says "Portal is already running" and then opens Portal. My mouse is recognized however any changes I make is not applied to the mouse even after I click the "apply" button after changes were made. When I close Portal and re-open it all my changes that I attempted to make are lost (even though they were never applied). I'm sure this is a software problem but I downloaded Portal from Cooler Master's website. I'd hate to send the mouse back because I can't customize it over the software. Please help!

Share this post


Link to post
Share on other sites
Edwin    0

UPDATE:

 

So I decided to plug in my mouse into another USB port since I have a USB port splitter that makes 1 USB port into 4 ports, and my computer started "setting up" my mouse which it didn't do before and then I tried opening Portal once again and everything started working. User error. Long story short I just needed to plugin my mouse into another USB port and everything started working.

Share this post


Link to post
Share on other sites
Wingus    0

I have exactly the same issue, except it makes no difference what usb port i use. Not only that, even windows doesn't recognise the drivers and installs it's own generic ones instead. Also, i find that the drivers will not update via the app. It recognises that there is one, but there is no mention of what the current firmware is, but tells me the new one to be installed. I click OK...sometimes that even gets stuck, then it hangs and stops the app working, the mouse just uses generic settings, cannot use it other than 2 buttons.

Edited by Stephen J Case

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.