AL

C700M LED malfunction

Recommended Posts

vortex31324    0

Yep, in the same boat with you guys. Has anyone here actually received a replacement top panel yet? If so, how easy was the replacement process? Timeline? And did it actually work?

 

I've already returned 1 case back to Newegg because it was within the return window. Unfortunately, this happened after their return window and it's the second case I've had. 

 

I really hope this can be fixed, I really like the case (when it works). It's beautiful and definitely is a statement piece, but if it doesn't work then that's really sad on the part of a ~$400 case.

20190217_214742.jpg

20190217_214816.jpg

Share this post


Link to post
Share on other sites
Angelllus    0

This is very bad service. I didnt like but understood the holiday break period (Lunar). Still no replies to any of my posts from staff or my support ticket. This is my last cooler master case, but to corsair i feel. Such a shame this case out side this issue looks so good. COOLER MASTER support whats going on? We shouldnt have to mass message posts to get responses?

 

Share this post


Link to post
Share on other sites
Genma    0

Got this reply from the support today :

 

Dear Sir/Madam,

Then most likely the LED's on top of the panel are faulty.
At this moment we do not have new top panels available with new LED.

We therefore suggest to return the case back to the store where you bought it from and replace the case with a new one. 

If you prefer to wait on a new top panel with new LED's, then please provide us your address and we will send out a new  top panel a.s.a.p. once we received them.

We are really sorry for any inconvenience. 

Kind regards,

Cooler Master Support

 

 

I remind them that this is my second case (following a first exchange). I asked if the new LEDs had a new revision that corrects the problem. I'm waiting for their answer.

.

Edited by Samuel MUTIN

Share this post


Link to post
Share on other sites
Genma    0

New message from the support :

 

Dear Sir/Madam,

We had a few customers with the same issue and after replacing the top panel including LED's the problem was solved. 
We have noted your address and will send out a new top panel with new LED's a.s.a.p. once we received these again.
We hope to have these available within 4-6 weeks (can be earlier).

Let us know when you have any other question and sorry for any inconvenience.

Kind regards,

Cooler Master Support

Share this post


Link to post
Share on other sites
vortex31324    0
On 2/18/2019 at 7:05 AM, Genma said:

Got this reply from the support today :

 

Dear Sir/Madam,

Then most likely the LED's on top of the panel are faulty.
At this moment we do not have new top panels available with new LED.

We therefore suggest to return the case back to the store where you bought it from and replace the case with a new one. 

If you prefer to wait on a new top panel with new LED's, then please provide us your address and we will send out a new  top panel a.s.a.p. once we received them.

We are really sorry for any inconvenience. 

Kind regards,

Cooler Master Support

 

 

I remind them that this is my second case (following a first exchange). I asked if the new LEDs had a new revision that corrects the problem. I'm waiting for their answer.

 

Yes please let us know, I'm on my second case too and I'm past the return window. I really don't want to pay shipping on this mammoth case for a RMA.

Share this post


Link to post
Share on other sites
Posted (edited)

This is this is such bullshit.

First this case is a disaster to work with for watercooling.
And my second led stripe just stopped working.

I paid a fucking 700 CAN $ for this case and this issue is not yet resolved.
I didnt receive any answer from the support and they closed my ticket with no answer. So now im stuck with 2 dead led stripes

Seriously, 700$ for this kind of crap. And the most important feature is the led design ( dont talk about their modular design )!!!

Edited by Micael Hevey

Share this post


Link to post
Share on other sites
Angelllus    0
Posted (edited)

I managed to get a whole replacement top for my case  (As one strip of RGB wasn't working), but not through here or cooler master support, my retailer I bought the case from (PBTECH.co.nz) dismantled a new case removed the part I needed (The whole top including the front panel IO) couriered it to me, I replaced the part and now all resolved (Courier back the faulty part). I still haven't had any reply regarding my support ticket or staff on forums. Its the retailer here in this case saved cooler master from me getting a full refund. I'd recommend you do the same (Even though you shouldn't have to lets be honest).

Edited by Angelllus
Spelling, Gramma

Share this post


Link to post
Share on other sites
Deniz Roth    2

They changed the Controller? I also have led malfunctions and downloaded the latest manual. Looked into it and noticed my Controller Layout Looks diffrent. I only have 1 sata Power Port and the one in the manual has two. 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.