AL

C700M LED malfunction

Recommended Posts

AL    0

As others have reported, the C700M appears to have some kind of issue talking to its LED strips (the two on top in my particular case). When powered on about 70-80% of the strips appear to be dead but will randomly come back to life over time -- albeit with whatever color it "saw" last, which tells me they're still able to partially communicate with the LED controller, but it's sporadic at best.

 

Anyway, opened a ticket a few days ago but I have yet to hear anything from Cooler Master so I figured I'd throw my hat in with everyone else having this issue. Kind of a disappointment considering the cost of the case, but I'd be content with receiving replacement parts (and installation instructions) since I know these things happen.

c700m.jpg

Share this post


Link to post
Share on other sites

Just today I got the same exact malfunction. Let me know if you hear back from them. I was in the middle of registering my product today to then afterwards address this exact issue

IMG_5885.JPG

Share this post


Link to post
Share on other sites
AL    0

Nothing yet (opened the ticket on Jan 9, so coming up on a week).

 

Did the whole Cooler Master team pack up and go to CES or something? Or is it normal for tickets to take a while to get a response?

Share this post


Link to post
Share on other sites

Yeah seems a bit silly to have that as the reason for any delays. I haven't ever submitted a ticket before so I'm not sure.

 

I bought my case November 2018 so it's been working fine up until now.

Share this post


Link to post
Share on other sites
AL    0

Good news! Called up the Cooler Master support line and got through to someone almost instantly. Here's what I know now:

 

- They're dealing with a backlog of tickets from over the holidays (hence the support delays).

 

- They're aware of the LED issue though I think it's still too early for them to know what the exact cause/solution might be.

 

- They're sending me a replacement top panel, and if the problem comes up again they said they can send another (though ideally after they've fixed whatever is causing this to begin with, because at that point it's likely a manufacturing defect).

Share this post


Link to post
Share on other sites

Thanks for the update AL, maybe I will call them up too! Did they make any mention of whether there will be instructions that come along with the replacement top panel?

 

Hope the best for you, and that it'll fix your problem :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now