Sign in to follow this  
Ben Cummmins

CoolerMaster MasterBox Lite 5 RGB Fans don't light up

Recommended Posts

Case came with 3 rgb fans at the front of the case and those 3 fans where linked to a coolermaster adapter which brought it down to just one lead. i've plugged that lead into the motherboard aswell as another cable involving the fan which i plugged into a molex cable straight from the psu, but i have no clue how to turn on the rgb lights or anything

Share this post


Link to post
Share on other sites

I'm having the same issue on the MB520 fans speed is controlled seperate from RGB for me. I pluged a fan rgb into my motherboard header and it works checked the power to the rgb controller thats good the item that appears to be the problem for me is the RGB controller. 

Share this post


Link to post
Share on other sites
On 12/31/2018 at 1:08 AM, Ben Cummmins said:

Case came with 3 rgb fans at the front of the case and those 3 fans where linked to a coolermaster adapter which brought it down to just one lead. i've plugged that lead into the motherboard aswell as another cable involving the fan which i plugged into a molex cable straight from the psu, but i have no clue how to turn on the rgb lights or anything

Hello,

can you find model no. of fans? 

Thank you

Edited by stonowinnerz

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this