Yang

C700M Front LED Problem

Recommended Posts

Neni    3
12 hours ago, Genma said:

 

I received the new pcb and I installed it. Everything finally works correctly! The new pcb is different from the old one: there is two connector for SATA power.

 

I ask Cooler Master to make a small gesture to compensate for all these problems, I await their answer.

 

Good luck to those who still have the problem. In the end three pieces must be changed to solve the problem: the front panel, the top and the pcb.

Can you post the picture of the new PCB, I would like to see all the differences between old and the new one? I still have the old one but its starting to act funny, occasionally (around twice a week) upper top right LED strip goes to trough the cycle of changing colors. So I'm waiting to go completely broke so I can ask for RMA.

Share this post


Link to post
Share on other sites
Genma    0
Posted (edited)

After a few days, I have the problem again despite the new pcb and new parts ...

 

 

20190420_130238.jpg

Edited by Genma

Share this post


Link to post
Share on other sites
C700M    0
Posted (edited)
Hello,
I am Japanese. I use translation software because I am not good at English.

March 20
 Coolermaster informs you that it will be repaired.
April 3
  bottom RGB confirmation question

The rest is left untouched.

DSC_0052.JPG

Edited by C700M

Share this post


Link to post
Share on other sites
Neni    3

Well I got today my replacement parts, PCB and top panel. The new PCB is the old model with molex connector, the same as the one currently in the case. Who knows if this one will go broke just like the old one. The old one went broke after 5-6 months.

Share this post


Link to post
Share on other sites

So yah my ticket was closed by the system with the message "your on the list when parts come in" that was on 4/4 ... still no sign of parts.. Thinking now I should have went with the 1000D or the Phanteks option.. Live and Learn I guess

Share this post


Link to post
Share on other sites
Neni    3
6 hours ago, Nicholas F Seabury said:

So yah my ticket was closed by the system with the message "your on the list when parts come in" that was on 4/4 ... still no sign of parts.. Thinking now I should have went with the 1000D or the Phanteks option.. Live and Learn I guess

 

Did you try opening another ticket? I've opened my ticket on 25th of April and they've sent me replacement parts on 29th, so maybe they've "lost" yours. But there is obviously a problem with the argb controller even after changing the PCB layout.

Share this post


Link to post
Share on other sites
1 hour ago, neno said:

 

Did you try opening another ticket? I've opened my ticket on 25th of April and they've sent me replacement parts on 29th, so maybe they've "lost" yours. But there is obviously a problem with the argb controller even after changing the PCB layout.

No, not till just now.. was taking them at their word that they where waiting for parts.. 

 

We shall see what happens with this ticket.. it should not be that hard for them to get a working controller thrown together.. the thing is which is the actual "working controller" the single Sata? dual Sata or single Molex powered board?

Share this post


Link to post
Share on other sites
Deniz Roth    2
Posted (edited)

Well they changed all parts of the case u need a new Front Panel, top panel and a new pcb with 2 sata Input. After changing all it works for me. Took 1 month for because they sent all one by one Tell Them they should Send all :)

Edited by Deniz Roth

Share this post


Link to post
Share on other sites
LuckyFox    0

Hey guys! I’ve bought mine on 28/03 and have experienced the same issues as all of you, top led going bananas, front leds not working at all, etc. I never contacted support as I could settle for a case without led by just turning them entirely off. But yesterday the PCB got a small fire and had a small explosion (like a gunshot sound). I highly recommend not buying this case and I am going to leave some reviews around the web.  Do you know if I can “wire” the connections plugged through PCB directly to MB? If yes is there a scheme?

img_20190619_203135.jpg

And here is the sign of the small fire on the case “door” cover:

img_20190619_203151.jpg

Edited by LuckyFox

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.