Sign in to follow this  

Masterkeys Pro L , unresponsive key

Recommended Posts

KIARAdars    0

Hi all!

Before write in here I've tried everything, but my Masterkeys Pro L has some issue with some key. I've searched the same problem here, and I've found this topic:

It's quite the same problem. My "w, e, a, s" key don't respond in the right way, even if pressed down for a few seconds! I don't know what to do, I've already tried all the options in that topic but the problem seems to return everytime.
Maybe RMA is the only option?


Thank you all for taking your time to read this post.



Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this