Arell Rodan

CM Storm Trigger lights up but not functioning

Recommended Posts

Arell Rodan    0

Good day, 


Last night I was still using my CM Storm Trigger keyboard, but then at morning when I turned on my system unit the keyboard light up, but unfortunately the keyboard doesn't work



           I tried using the Storm Key+ 1/2/3/4/5 , doesn't work

           Tried pressing all keys including caps lock, screen lock and numlock doesn't work (the lights on Caps, Num and Screen lock doesn't lights on or lights off when pressed)

           Tried reattaching the USB Cord, it lights up but still doesn't work

           Viewed attached devices and my system unit recognizes the keyboard as CM Storm Trigger 

           I have the latest keyboard drivers

           Also tried resetting my system unit

           Keyboard was a tournament prize last 2014, I rarely used it because I didn't have a pc before, if i'll add up the total days I used a keyboard it could only be for 2-3 months 

           Keyboard's USB Cable are still in good condition

           Keyboard's in good condition too never been dropped nor spilled water or any liquid on it


Things I'm still looking to do:

            Download, install and use software from your site ( I actually downloaded this but never actually used it as my keyboard was working perfectly but until now)

            Message or file a ticket directly to your support


Details : System unit was built and just used this June 2018 ( IDK if this matters but I hope it helps )

           Proce : Amd Ryzen 5 2400g

           Mobo : Gigabyte A320-S2H

           RAM   : 8GB 

           OS       :WIN10





Share this post

Link to post
Share on other sites
Cheeseball    0

I've had this problem with the keyboard since 2014.  It has sat in a box near my office desk since then.  I was given an RMA but I declined to send it in as shipping was $45 and this is almost certainly a problem that can be solved by flashing the board.


Whatever.  Coolermaster lost a customer.

Edited by Cheeseball
I used the Reset Trigger tool and it fixed the keyboard. I'm happily using it at home now.

Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.