Recommended Posts

Renato    0

Hello,

 

I have a Seidon 240M for about 3 years now and suddenly the CPU fan stopped spinning.

Unless you have some suggestion that doesn't need to open if, I would like to know how to open to try to fix myself, but I couldn't find anyone that tried to open this exact model.

I don't see any normal screws on the top of it, I only see the many triangle screws below it, around the center of copper and I don't think that's the way to open it.

There is one gray round rubber on the top that seems to be removable, but its not so easy and I dont know if thats the way too.

 

By the way, I am sure it's the fan, not the motherboard or connector or any other thing.

 

Any help?
Thanks.

 

 

seidon 240m.jpg

Share this post


Link to post
Share on other sites
Mohd Noh    30

Hello

This is just suggestion 

1. Try clean UP your Cooling

2, Try reapply back the thermal paste and Reseat ( unplug the wire )

3, Try Unscrew the radiator and shake it a bit, do you hear any water splashing around?

4, Try touching our customer services ( how to open the cooling ) and they will assist you .

By the way 3 year  is pretty long or good enough .

Share this post


Link to post
Share on other sites
Renato    0

Hello and thank you for your reply,

 

1. My cooling is pretty clean

2. Tried that already before posting

3. No water splashing around

4. Tried, no reply so far

 

I am sure its the fan inside of the pump because it shows its not spinning: 0 RPM. Doesnt matter at what connector I plug it on the motherboard.

All fan connectors were tested and are working, but when I plug the pump, it doesn't spin, so can only be the pump.

 

Plus, like I said, it was working just fine and suddenly stopped.

Share this post


Link to post
Share on other sites
Renato    0

I sent a ticket, but don't know if they will reply.

I want to open it to see if I can fix it myself, but I can't find anywhere how to open this exact model.

I found some people opening other versions like 120 or 240v, but not this one and I don't see any screw on top of ir below it that would open it.

 

Here are some pics of the top and below.

 

My best guess is that round gray thing on top of it. It seems removable, but not so easly. Maybe there is a screw under it.

Any thoughts?

seidon 240m below.jpg

seidon 240m top.jpg

Share this post


Link to post
Share on other sites
Mohd Noh    30

Can you pm your ticket number ?

Next monday i will ask someone at HQ 

Share this post


Link to post
Share on other sites
Renato    0

Sure thing. Sent pm.

About opening it, you dont have any idea looking to the pictures?

Share this post


Link to post
Share on other sites
Mohd Noh    30
5 minutes ago, Renato said:

Sure thing. Sent pm.

About opening it, you dont have any idea looking to the pictures?

Actually i dont have any experience with this cooling that why im suggested you to open the ticket .

Honestly 3 years is pretty good long enough maybe you have move to new cooling

Share this post


Link to post
Share on other sites
Renato    0

I see.

I thought you might have some idea if I was right or wrong about removing that round gray thing.

If the support doesnt reply on a few weeks, I will try it anyway.

Thanks!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now