Tekmicro

Extremely slow RMA 3 months+ (Solved )

Recommended Posts

Tekmicro    1

So, I started 2 separate RMAs sent both on november 22nd 2017. I still have 0 news about, no wherabouts tried calling every week, no one answers no one calls back very dissatisfied awful customer support.

 

AVOID at all cost.

Share this post


Link to post
Share on other sites
Mohd Noh    28

Hello ,

I will share this issue to the HQ team so can you pm me your ticket number ?

 

Share this post


Link to post
Share on other sites
Tekmicro    1

I am still waiting for these 2 units waiting time is UNACCEPTABLE. terrible customer support.... 4 months for 2 power supplies, without ANY contact from coolermaster besides Mohd Noh on the forums.

 

Seriously I can understand that they were backorder for a few weeks but not a single G650M got out of the factory in 4 months ?? 

  • Upvote 1

Share this post


Link to post
Share on other sites
Mohd Noh    28
1 hour ago, Tekmicro said:

I am still waiting for these 2 units waiting time is UNACCEPTABLE. terrible customer support.... 4 months for 2 power supplies, without ANY contact from coolermaster besides Mohd Noh on the forums.

 

Seriously I can understand that they were backorder for a few weeks but not a single G650M got out of the factory in 4 months ?? 

Hello

Sorry for all of this

Next Monday i will ask them again ( status your RMA )

  • Downvote 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now