BPA100

Masterliquid lite 240 extremely loud

Recommended Posts

BPA100    0

I installed the MLL 240 a few hours ago and I'm sitting here thinking it's really, really, REALLY noisy. One of the reasons I went for the MLL 240 is that it's supposed to be really quite. It's my first watercooling build so I might have done something wrong, though I'm perplexed as to what it would be. The cooler works just fine and it seems to be good at that but my god the noise .
It's like any other fan sound, just LOUD.
Is this normal or have I installed it incorrectly ?

Hope for some help here. 

Share this post


Link to post
Share on other sites
BPA100    0
1 minute ago, Mohd Noh said:

 

I have the masterbox 5 lite rgb chassis. It's installed behind the front fans. It's the only place to install it. I read both posts before I made my post but they dont give any answers. The pump IS working just fine. It's just very loud and I'm confused bcs its supposed to be the opposite

Share this post


Link to post
Share on other sites
Mohd Noh    29

Can you share some picture ?

Did you try to replace it with other fans ? or try to reinstall ?

If still same issue i love suggest you by contacting our services for the next step ( might your fans faulty unit )

Share some experience , before move to RGB cooling i also have same issue like you facing right now , what i am doing is take out and install it back

Pump connector > Sys fan header and the Fans Connector > Cpu fan header + Run in full speed 

Remember if you still get same problem > please touch our customer services via ticket and they will assist you .

Share this post


Link to post
Share on other sites
BPA100    0

I tried reinstalling it twice, still very loud. I haven't tried other water cooling systems if that's what you mean, but I have 3 air fans which are all 100 times less noisy.
everything is connected correctly. I haven't used any controlling software for the fans, so I'm unaware of the % of speed they are running with.

I'll try and get some pictures uploaded 

Share this post


Link to post
Share on other sites
Mohd Noh    29

Hello,

Please contact our customer services for the next step

Probably the fans is defective or faulty unit .

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.