New out of the box ML120L not working!

Recommended Posts

badrum    0

I bought a brand new ML120L (from Amazon) and installed as per the instructions. It does not seem to working properly. Looking for some troubleshooting help. The ML120L started up fine. All lights worked. Fan started, etc. From boot up, my CPU temp would climb steady, even at idle, to 105°C! with the ML120L installed. I have since reinstalled the stock heat sink, the CPU temps have now stabilized under 50°C. Same thermal paste used to install the ML120L, and then reinstalling the stock heat sink.


Stock Heat Sink before = 50°C

ML120L = 105°C!

Stock Heat Sink reinstalled = 50°C


System Info

Intel i5-3750K @ 3.4 GHz (not overclocked, was planning too with installation of ML120L)

Gigabyte GA-Z77X-D3H Mobo

16Gb Ram

GTX760 2Gb Video card

750W gold Power Supply




Share this post

Link to post
Share on other sites
badrum    0

Mohd Noh;


     Thank you for the support. The first link (Liquid Cooling: Where do I connect the Fans and Pump?) did the trick. On my Mobo (GA-Z77X-D3H) has a 3 pin port under the CPU fan port labeled DAJP1. I had connected the pump to that port, which allows the system to start, but does not power the pump. I have since moved it to System Fan 2 port. Idle CPU temp now under 30°C.


Share this post

Link to post
Share on other sites
Mohd Noh    29

Well now your issue has been solved right ?

If you still have same issue , i love suggest you by contacting our customer services and they will assist you

Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.