nimitzu

Masterkeys Pro S * some keys randomly stop working *

Recommended Posts

nimitzu    0

i bought masterkeys pro s 3 months ago. It was working fine for 2 months but in last 3-4 weeks first my *e* key stopped working but not completely. Atm my e-y-w and caps lock keys sometimes dont work or i have to press really hard to make it work. Anyone having these kind of issues? Do i have to return it or is it just an programmatical issue?

Edited by nimitzu

Share this post


Link to post
Share on other sites
Mohd Noh    29
1 hour ago, nimitzu said:

i bought masterkeys pro s 3 months ago. It was working fine for 2 months but in last 3-4 weeks first my *e* key stopped working but not completely. Atm my e-y-w and caps lock keys sometimes dont work or i have to press really hard to make it work. Anyone having these kind of issues? Do i have to return it or is it just an programmatical issue?

Hello 

Did you try disconnect and replug again ? or did you try to others system ?

If still facing same issue > RMA + please contact our customer services .

Share this post


Link to post
Share on other sites
nimitzu    0
2 hours ago, Mohd Dzuld said:

Hello 

Did you try disconnect and replug again ? or did you try to others system ?

If still facing same issue > RMA + please contact our customer services .

i tried both of that things u referred to. whats RMA exactly?

Share this post


Link to post
Share on other sites
Mohd Noh    29
16 hours ago, nimitzu said:

i tried both of that things u referred to. whats RMA exactly?

Hello,

before and after

Before this your KB serving you without fail right?

After that your KB cant serving you ( as you like ) right ?

Try check if there port or driver need to update  or reset your KB ?

If still facing same problem > please get our customer services for the next step .

 

Hope this can help

 

Share this post


Link to post
Share on other sites
sam    0

@nimitzu any luck with your issue or did you have to send it in to Cooler Master?

 

I'm having a similar problem where my tab key will only work when I push down very hard and use a lot of pressure. All the other keys work fine and will respond to a gentle push.

Share this post


Link to post
Share on other sites
DagicCross    0

I am having this issue as well, where as my 'a' letter would not be registered and sometimes it could register twice in a row. I had this keyboard for more than two years now, don't think I could get RMA anymore... my keyboard still looks new sadly :(

Edited by DagicCross

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.