Theadultchild

Master Pro 240 loud noise issue

Recommended Posts

So installed my pro 240 4 weeks back, no problems. No issues. Started it up 3 days ago, constant flicking or maybe just fan noise coming from the pump, really annoying and constant. Is this the norm from the coolmaster range im seeing a lot of threads on the issue. Should i take the whole thing back for a refund if this  is the norm of the quality? i have a video with the noise by you cant even but them in the thread  hows a picture going to get my noise issue across?

Share this post


Link to post
Share on other sites
Mohd Noh    29
9 hours ago, Theadultchild said:

So installed my pro 240 4 weeks back, no problems. No issues. Started it up 3 days ago, constant flicking or maybe just fan noise coming from the pump, really annoying and constant. Is this the norm from the coolmaster range im seeing a lot of threads on the issue. Should i take the whole thing back for a refund if this  is the norm of the quality? i have a video with the noise by you cant even but them in the thread  hows a picture going to get my noise issue across?

Hello there ,

The MLP 240 should be in silent operation

First you bought and after a few week the MLP 240 starting making noise right and the noise coming from the fans right ?

I believe that the fans is going down meant is defective or faulty unit .

My suggestion please touch our customer services for the next step .

 

Hope this can help .

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now