Ghost_Leader07

CM won't respond to my emails regarding an ongoing RMA proccess

Recommended Posts

Hi Guys,

 

I need your help regarding the horrible CM RMA process, i've been contacting CM support for more than a week asking about updates regrading my RMA but i've got nothing no response at all despite receiving my unit weeks ago yet not a single email. they've already passed the estimated time of sending a replacement... my RMA status is saying "Action Done" can anyone tell me what it means since i'm not getting any help or clarification from them.

 

i'm getting frustrated and this is most likely the last time i'd buy a Cooler Master product. i honestly regret choosing CM over other brands.

Share this post


Link to post
Share on other sites
LABU163    0

same thing its happening to me please help.. i been waiting for a month for a replacement to ship out 

Share this post


Link to post
Share on other sites
Afshin    0

Hi dears

I have a V 1200 cooler master PSU that had  gone off  and couldn't power on that again.

I've checked the outputs and there is 1.1V

Where should be 12V

I'm living in Iran, how can I use warranty services and support of cooler master?

 

Share this post


Link to post
Share on other sites
Mohd Noh    28
12 minutes ago, Afshin said:

Hi dears

I have a V 1200 cooler master PSU that had  gone off  and couldn't power on that again.

I've checked the outputs and there is 1.1V

Where should be 12V

I'm living in Iran, how can I use warranty services and support of cooler master?

 

Hello ,

You can contact our customer services , they will assist you

Share this post


Link to post
Share on other sites
Travis    0

I have had a CS ticket in for a failed 1200w PSU for 19 days with no response at all.. I have followed the process for a warranty issue through CM convoluted customer support system and don't even get the decency of a response email.

Share this post


Link to post
Share on other sites
Mohd Noh    28
On 21/2/2018 at 4:04 AM, Travis said:

I have had a CS ticket in for a failed 1200w PSU for 19 days with no response at all.. I have followed the process for a warranty issue through CM convoluted customer support system and don't even get the decency of a response email.

Hello can you pm me your ticket number ?

Share this post


Link to post
Share on other sites
Travis    0

Ticket # 00115782 - Still open with no response or communication for a month.. It was the 20th when you said that you would forward my issue off for assistance and yesterday you ask for a ticket number in a forum I would have no reason to constantly monitor? Guess its a good thing I happened to check today..

 

v1200 platinum PSU

Powers off randomly

Verified by replacing with EVGA unit without issue 1/31/2018

EVGA has not powered off once since install

Ticket created 2/3/2018

 

 

Share this post


Link to post
Share on other sites
Mohd Noh    28
2 hours ago, Travis said:

Ticket # 00115782 - Still open with no response or communication for a month.. It was the 20th when you said that you would forward my issue off for assistance and yesterday you ask for a ticket number in a forum I would have no reason to constantly monitor? Guess its a good thing I happened to check today..

 

v1200 platinum PSU

Powers off randomly

Verified by replacing with EVGA unit without issue 1/31/2018

EVGA has not powered off once since install

Ticket created 2/3/2018

 

 

Hello ,

Sorry for all of this but FYI your ticket already forwarded to the related team however i will ask them again by today again 

I will PM you once i get any info from them .

  • Downvote 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now