mimesot

Storm Stryker fan control problem: suddenly at maximum speed

Recommended Posts

mimesot    0

Hello everybody!

I was wondering if anybody already encountered the same problem. I searched the forums briefly and didn't find anything related.

 

I usually run my case fans - all of which are connected to the cases fan controller - at the lowest possible speed, as I hardly generate any heat inside the case. Then, yesterday, when I was working on my computer for several hours, all of a sudden, the 200mm top fan and the 140mm back fan spun up to maximum speed. I did not notice anything providing a proper cause. There was no way to get the fans back to a low rotation frequency. Though I did not expect it to work, but simply to rule things out, I tried changing the fan controller on the front panel to maximum and back to minimum, and I shut down the system, gave it some time to rest and rebooted. Didn't work.

 

I further noticed that this happened to just those two fans, while the two front fans remained unaffected. I could still regulate those. This makes sense, as both, back ans top fan, are connected to the fan controller with the brown cable, which has a Y-connector, and should thus be attached to the same voltage. The front fans have both individual connectors.

 

In order to rule out a fan failure I plugged the fans into the motherboards system fan connectors. I was able to adjust the fan speeds to a desired level in the BIOS ... eeh UEFI.

 

What might have happened? If a 3 pin fan has just 2 pins connected it behaves like a 2 pin fan, right? Could this mean, that the control pin/cable failed? But wouldn't that require at least some mechanical stress or ... something? How can I find out what is malfunctioning? Is there a way to fix it? (I purchased the case just 7 month ago so I should avoid invalidating my warranty)

 

If anybody has a clue, thanks a lot in advance!
Kind regards

mimesor

Share this post


Link to post
Share on other sites
Sebastian    0

 

Hello, I wanted to know if you found a solution? For me in the Trooper case fans and lighting restart after turning the computer off and on again to max speed. I can control them to increase and decrease speed but at every computer startup all fans go to the max. I am beginning to wonder if it is not the fault of the front control panel and will it help me exchange it?

Edited by Sebastian

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.