Jeff Panian

HAF XB EVO - Quality Control?

Recommended Posts

Jeff Panian    0

Brand new HAF XB EVO - here is my review.

 

Quality control is a major issue, either that or the race to the bottom price has caught up with CM.

I have an older HAF case I love, so I decided to purchase a new one for a new pc build.  All new parts, all from newegg direct.  Gigabyte MB, Intel i5 7500, Gskill 3200 DDR4, SeaSonic bronze certified PSU, CM 212X Cpu fan.  Onboard video for power to bios testing.

First issue out of the box - the 200mm top case fan is NOT 200mm.  The rubber grommets in the mesh are not even square, but rectangle.  

 

Second issue on first power on - the SATA power connector of the hotswap board LITERALLY caught on fire!  (Pictures)  The sata power cable to the PSU is a high quality Thermaltake braided line I've used without issue in my old machine.  I chose to use the thermaltake power cable, because the SeaSonic ones were not braided and seemed lower quality.  Plus the one I used was proven good.

 

Third issue - I have no idea, the damn thing caught on fire.

 

After I pulled the hotswap board, the machine fortunately powered on to the BIOS.  I have not tested any of the functionality, as I haven't had time to re-install new power cables, and directly connect the drives to MB.  I hope the SDD primary 120g OS drive and 1TB 7200 storage drives are not damaged.  It appears the damage was contained to the connector, so hopefully the surge didn't hit the drives......  I'll update after I test the drives, and hear back from my service ticket here at CM.

HotSwap_Overview2.jpg

HotSwap_Power Connector.JPG

HotSwap_with_Sata Power.JPG

Share this post


Link to post
Share on other sites
ajfaull    1

You say you are using a Thermaltake SATA cable with a Seasonic power supply? 

 

Every manufacturer, and in fact even different models within some manufacturers use different pinouts on their cables coming out of the power supply. I know even when I had to upgrade my system from a Coolermaster 750 Power supply to the 1000w that I got as an RMA replacement a couple of years back, the cables had different pinouts. If I had used the same SATA, Molex or other power connectors to go from the drive connectors to the power supply likely would have caught fire.

 

Use only the cables that come with the power supply with that power supply. If I RMA a customer's power supply and even get one of the same brand and rating, just to be safe, I will re-run all the cables with the cables that come packaged with the power supply, or a proper replacement such as those from Cablemod.com to verify that the cable is the same as needed for my power supply.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now