Sign in to follow this  
Grey Peterson

Power supply being too loud?

Recommended Posts

So for months the excessive noise of my computer has been bugging me. I installed a watercooler and it didn't stop. What bugged me more is the fan noise was exactly the same as it was before replacing my aircooler with a watercooler. I finally figured out that the noise is my power supply fan. Never once have I had a power supply make so much noise under load. Never. And there's nothing out there in the way of software to read its temp or adjust its fan usage.  Now I'm wondering if somehow it's under-rated and overheating, but it gets noisey even when my cpu is only around 20% load and not drawing that much power. The power supply is a Cooler Master Elite V2 - 550W Long-Lasting Power Supply with Full Electrical Protection (OVP/UVP/OPP/OCP/SCP). My computer is running a Gigabyte Z270 motherboard with an i5 7600k cpu with no overclock, 1 hard drive, 2 solid state drives, 8 GB of ram, an NVIDIA GTX 770 (which was not under load at the time) and a watercooler for the processor. I don't have a tool to measure how many watts the computer is drawing as a whole, but my CPU doesn't draw much power without an overclock and my graphics card is in here just to give me three displays, and is never under gaming load, and never draws much power. So why is it that doing something as simple as scrolling Facebook is causing my power supply to become so annoyingly loud? I thought these things only got loud when they were overloaded. 20% CPU utilization on an i5 and an under-leveraged gpu shouldn't be stressing a 550watt supply this badly. It's also worth noting that this build is only a few months old; I built this PC in April of this year, and I've had this problem since day one.

 

Edit: https://youtu.be/GeHgCUFzw6c

Here's a video to show how loud it is. I opened Firefox and went to Facebook and this is what I started to hear after 20 seconds. Note that I wasn't even scrolling at all, and the PSU would not calm down until I closed every Firefox tab I had open.

Edited by Grey Peterson

Share this post


Link to post
Share on other sites
knud    123

This PSU is not the most silent one, but it seems that the fan is running on 100% fan speed.

You can submit a support ticket and our support guys will help you further.

Share this post


Link to post
Share on other sites
16 hours ago, knud said:

This PSU is not the most silent one, but it seems that the fan is running on 100% fan speed.

You can submit a support ticket and our support guys will help you further.

I submitted a ticket but the only response was an offer to do a warranty swap for a new one. At this time I'm not sure I want to rip apart my rig and leave it non-functional while going through the swapping process.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this