Sign in to follow this  


Recommended Posts

GuiZ    0


I bought the CM Storm Devastator Boundle 5 months ago , all works fine but now , the mouse ain't working anymore: the lights are ok but when i move, click or scroll nothing happen.

I've tried to change USB port, unistall drivers, reboot my pc and plugged it on another computer.

Maybe there is a problem with the last windows update (Win 10) ?

When i access to Devices Management it says : "Unknown USB Device (Desired Device Descriptor Failed)"




Edited by GuiZ

Share this post

Link to post
Share on other sites
Sunday Morning    177

Welcome to CM forum .

Hi Guiz , im owner this kit too from windows 7 and now win 10 serving me without any fail . concept this kit is plug and play 

1, Try check this link : [Solved] Unknown USB Device (Device Descriptor Request Failed) for Windows 10

2, Please issue ticket to customer service , they will help you .

Share this post

Link to post
Share on other sites
Sachin    0

Well, this error might encounter due to any outdated driver or your driver isn't working well.

1. There are several fixes to this problem and you should check an article about device descriptor request failed .

2. Try restoring your PC to previous versions.

3. Check whether device is working well on another PC's or not.

Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this