WSeong Lee

Masterwatt Lite 600W weak 12V output

Recommended Posts

WSeong Lee    0

Just switch my old PSU to this new Masterwatt Lite 600W once everything setup done, I start up hwinfo64 and found that the 12V output on idle is 11.808?

That output is consider low as this is a brand new PSU!

Fire up a game and log the voltage, it is shown 11.808 max and min drop to 11.616 during heavy load.

How can this be? even my 10 year old PSU Acbel 450W perform better with max at 12.096 and min 11.712

 

my system is just a basic rig:-

i3-4160, 8GBX1 DDR3 RAM, GTX750Ti(no external source),Hyper 103 cooler

onboard speaker, gaming mouse and keyboard via USB, 2 512GB SATA Harddisk

Share this post


Link to post
Share on other sites
knud    120

Reading out PSU voltages from software is never 100% accurate. 

If you have a voltmeter, you could use that to measure the 12v line.

 

11.6v is a bit low, it is well within the 5% margin that is allowed and the PSU will work as intended. 

Share this post


Link to post
Share on other sites
WSeong Lee    0
Posted (edited)

11.6 is more than a bit low, consider it is a new PSU, even my BIOS reading on start up confirm is 11.808, either the sensor is wrong or this is really a weak PSU.

 

I am more concern if the PSU can hold on for the 3 years warranty period, and if the PSU drop below 5% margin, will I able to claim a warranty.

Edited by WSeong Lee

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now