Nenad

Apostrophe key unresponsive

Recommended Posts

Nenad    0

I have just bought Masterkeys Pro M and everything works flawlessly - except that for whatever reason the apostrophe key does not seem to work properly. It is the only key that does not backlight when pressed, either (actually, it does, but randomly, every once in a while). It seems like some sort of mechanical failure, which I did not expect, as Cherry MX has been getting excellent reviews. Is there any way to remedy this? Thank you in advance!

Edited by Nenad

Share this post


Link to post
Share on other sites
xorly    1

It looks like a problem with keyboard itself. HW problem, probably soldering. Easiest would be if you return KB to seller and get new one.

 

Possible problem, not fixable without warranty void.

If switch works properly, most probable is bad soldering on LED. Change backlight to continuous mode and try pressing that key. Occasional flashing confirms problem with soldering...

 

Share this post


Link to post
Share on other sites
Nenad    0

Easiest would be if you return KB to seller and get new one.

 

Thank you, xorly! That's exactly what I did earlier today - I got a replacement and everything works great!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.