Sign in to follow this  
Paul Truzzi

OS Sensitivity Won't Stick

Recommended Posts

Paul Truzzi    0

My MasterMouse Pro L had been working fine for the first couple of months. But around the time I added a 3rd monitor, the OS Sensitivity got screwed up.  I use the software to set the sensitivity at 4 and apply it. Everything seems to work, just like when I write new macros and save them. But on a reboot the OS Sensitivity will be up at 7.  How do I get it to remember the new setting if Apply doesn't do it?

Share this post


Link to post
Share on other sites
mousse    0
Posted (edited)

i just purchased four of these mices because the specs seemed very nice for the price. but i am disappointed due to the following reasons:

 

the cable: super stiff. i seriously wonder how this was deemed as acceptable/good!?

 

the weight: too high.

 

the shape: it is not large at all, does not make justice to the name. too narrow and small, i still prefer the shape of my intelli mouse explorer. the included plates are too similar in terms of size, i wonder why they are not made more different from the standard ones, would have hoped for a bigger shape difference (larger). the underside edges are too sharp, when lifting the mouse tilted the edges are making a scraping noise on my cloth mouse pad.

 

the button layout: the button on the right side (opposite forward button) are pressed easily by accident when pressing the left side. especially in the standard settings with the storm tx function being activated accidentally it is very annyoing. i thought the mouse is bugged first. the buttons are too far in the back, especially the backwards buttons on both sides.

 

the software: the sensitivity settings are not saved upon startup unless the software is started, very annyoing. the interface is not very good in showing what mode is being used for the leds, you can apply multiple lighning modes at the same time somehow and it does not show that you can choose the lights individually. from a ui perspective the software is just clunky and unclear to me. not possible to delete profiles, i just need one. please make it more simple and easy to understand. logitech is doing a much better job there i think. don't make it two programs, one is enough.

 

seriously, that cable and the wrong sensitivity settings upon startup (when software autostart disabled) are huge flaws to me...still scratching my head... :)

 

 

 

 

Edited by mousse

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this