Tyson

Brand new 240 leaking out of the box.

Recommended Posts

Tyson    0

I bought a liquid pro 240 cooler last weekend and went to install it tonight on my new build. When I removed the block from the box I noticed that there was liquid around the entrance to the hoses in the block (both sides) Please see photos. I believe that this may be defective and did not install it.
I am now stuck with a new cooler and no computer as I do not want to risk putting this in my machine and have it leak over everything and ruin all of my components. 

Is this a common problem?  I assumed it is the water from the cooler. But when I felt it it feels a bit like oil.

IMG_7201.JPG

IMG_7203.JPG

IMG_7204.JPG

IMG_7205.JPG

Share this post


Link to post
Share on other sites
Tyson    0

Ok. Thanks. 

I was thinking that it could be an oil or some kind of lubrication from the moving of the tubes on the block.   Not sure if this is normal or not. I've touched it and it felt like oil and the little amount that I wiped up hasn't come back. 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.