Sign in to follow this  
ajfaull

Power Supply dead again.

Recommended Posts

ajfaull    1

August of last year (2015), Coolermaster decided that my M series power supply was in fact dead and exchanged it with a Vanguard V1000 PSU after many weeks of waiting.

 

Well that power supply is now dead after 15 months, apparently replacing the PSU the first time has eaten what was left of the warranty because RMA is not finding a warranty on the PSU.

 

After having two dead PSUs within the five years, I hope there is a way to rectify this. 

Share this post


Link to post
Share on other sites
madwheel    0

I'm no rep, but have you hooked up your PSU to a good surge protector or UPS system?  My Cooler Master PSU has been great aside from a fan issue.  Even my cheapo PSUs on test machines have never failed, but they've always been protected from spikes.

Share this post


Link to post
Share on other sites
ajfaull    1

Both times my PSU died, I have had them on an isolated line, with surge protection at the breaker, and a APC 1500W ups with brown out protection.  All alarms are turned on on the UPS including undervoltage, brown out, line failure, surge.

Edited by ajfaull

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this