VirtualDanny

Nepton 240M Pump noise (with video)

Recommended Posts

Hello,

I'we been happily using my CM Nepton 240M since september this year.
Yesterday my PC suddenly started to make some strange noise, and I identified it to be the Nepton 240M pump "house".

Since the noise was pretty high I could record it and put out a video of it as well, please see below.
Is there anything I could do, or should I contact my vendor for a new one/RMA?

Thank you.

 

Edited by VirtualDanny
changes

Share this post


Link to post
Share on other sites
Mohd Noh    179

Hey Danny ,

Oh man .. the sound .. too bad ... 

Before you submit RMA or Return to your vendor // local shop , My suggestion try reinstall your Nepton and see how the result ... if still facing same issue ( RMA or Return it )

Hope this can help .

Share this post


Link to post
Share on other sites
Tony H    0
On 11/26/2016 at 2:36 AM, VirtualDanny said:

Hello,

I'we been happily using my CM Nepton 240M since september this year.
Yesterday my PC suddenly started to make some strange noise, and I identified it to be the Nepton 240M pump "house".

Since the noise was pretty high I could record it and put out a video of it as well, please see below.
Is there anything I could do, or should I contact my vendor for a new one/RMA?

Thank you.

 

I just brought the masterliquid 120 and I am getting the same noise . I have reseated twice but it is still there .. it is driving me crazy !!!

I have about 5 days to return but Damm it kills me to have to remove the motherbroad to remove the bracket.. Geez what was your solution ?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now