Sign in to follow this  
Lov2Drift

Need a little help

Recommended Posts

Lov2Drift    0

I bought the Real Power 450W PSU and it came with that wattmeter to mount in the 3.5 bay. I've got a centurion 5 case and for the life of me I couldn't get the silly thing to mount correctly. is there any way to do it so i dont have to drill holes into the case for some screws?

Share this post


Link to post
Share on other sites
Cobra19    0

i'm not too familiar with the C5 and the meter...why exactly can't u get it to mount..are the holes not lined up properly..?If u can get some pics that'll help alot...i'm gonna try to contact one of the mods to help u..

i only have experience with the wavemaster and the wattage meter so far...

Share this post


Link to post
Share on other sites
Lov2Drift    0

i'm at work right now but when i get home i'll take pictures of the meter and the case to hopefully illustrate my issues.

its mainly a depth issue from the way i'm looking at it. when you push the locks forward its not grabbing the meter so it won't sit in the bay without screws holding it in.

Share this post


Link to post
Share on other sites
Mr. Miyagi    2

In some cases it's going to be a little loose. I have a C5, but mine is where the Firewire/USB ports are.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this