The Brapp

MASTERKEYS LITE L COMBO PROBLEM

Recommended Posts

The Brapp    1

Hi all,

just received my new keyboard, looks great.

I have an issue whilst gaming and wondered if anyone else has has this.

When pressing keys, such as "W" and "Tab" the key doesn't stay pressed, its like you are hitting it multiple times. So when you are driving, the accelerator does stay down and it cuts in and out and you don't get to full speed. Its the same with helicopters, you keep falling until you lift your finger and press down again.

Is this a problem with the keyboard or something else?

Regards

  • Upvote 1

Share this post


Link to post
Share on other sites
LittleKing    4

Received this bundle today and had the same input problem. After watching a few youtube reviews I came across one video where the girl mentioned the repeat rate, F9 and F10. Once I loaded up a game I confirmed that THAT was the problem. The 8x repeat rate messes with the directional inputs. Setting it back to the standard 1x (FN+F9) fixed it right there. I could even switch between the two to make sure that it was the culprit. 

I hope this helps anyone who is having this problem! =)

Edited by LittleKing
  • Upvote 4

Share this post


Link to post
Share on other sites
On ‎3‎-‎10‎-‎2016 at 9:31 PM, LittleKing said:

Received this bundle today and had the same input problem. After watching a few youtube reviews I came across one video where the girl mentioned the repeat rate, F9 and F10. Once I loaded up a game I confirmed that THAT was the problem. The 8x repeat rate messes with the directional inputs. Setting it back to the standard 1x (FN+F9) fixed it right there. I could even switch between the two to make sure that it was the culprit. 

I hope this helps anyone who is having this problem! =)

OOO MY GOD THANK YOU!!! I  was having the same problem, and after searching the internet I stumbled across this. I can confirm that this helps.

Share this post


Link to post
Share on other sites
Vitor    0
On 03/10/2016 at 4:31 PM, LittleKing said:

Received this bundle today and had the same input problem. After watching a few youtube reviews I came across one video where the girl mentioned the repeat rate, F9 and F10. Once I loaded up a game I confirmed that THAT was the problem. The 8x repeat rate messes with the directional inputs. Setting it back to the standard 1x (FN+F9) fixed it right there. I could even switch between the two to make sure that it was the culprit. 

I hope this helps anyone who is having this problem! =)

logged in just to upvote this. You rock!  ;]

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now