Erktangle

CM Storm Quickfire TK buggy on iMac with OS X El Capitan

Recommended Posts

Erktangle    0

I have the Quickfire TK (red)  and I love it (the thin apple keyboards had convinced me I was mildly dyslexic for a few years, switched to a mech keyboard and suddenly my wpm almost doubled), but I've been having an issue since I started working on my desktop more often. I'll plug in the keyboard and it lights up and works fine for a while, but will suddenly cease sending input to the computer, seemingly at random. The lights will stay on, but none of the keys register with the computer. If I unplug the keyboard and plug it back in again, it works fine, so it's not a crazy issue, just an inconvenience. 

Is there a driver that I haven't found that I need? Has anyone else had this issue? If I'm not providing enough info on my situation I can try to clarify further.

Thanks guys!

Share this post


Link to post
Share on other sites
knud    124

I'm not too familair with iMac or apple pc in general, but would it be possible it somehow stops providing sufficient power to the keyboard? (Sleep mode?)

Are you able to check/test the keyboard on a different pc or laptop?

 

As for drivers: there are none needed and we do not have mac osx drivers in general.

Share this post


Link to post
Share on other sites
swallow    0

I actually have very same problem.

I'm using 3 different CM keyboards.

CM Storm QuickFire Pro on old Mac Pro (since OS X 10.9 and now 10.11; keyboard purchased in 2013)

CM Storm QuickFire Rapid-i on 2012 MBPr (OS X 10.11; keyboard purchased last year)

CM Storm QuickFire TK on iMac 5K (OS X 10.11 and purchased a few month ago)

I have same symptom on Pro and TK.

I never had issue with Rapid-i.

I even tried Rapid-i on iMac 5K and TK on MBPr.

Same problem with same keyboard.

LED stays on but keyboard stop responding to keypresses.

It happens daily and happens almost 24 hours from last connection/reconnection.

It's very consistent on how often it happens.

That consistency is not 100% everytime but almost.

More like 99%.

Duration varied before but it's been consistent for over a year now with El Capitan.

I see a couple connections here.

Pro and TK use Mini USB and Rapid-i uses Micro USB (I don't believe this itself shouldn't make any difference but having different connector may mean different firmware group that would put Pro and TK in same group but Rapid-i in different group).

Pro and TK doesn't have any firmware update but Rapid-i did which I applied as soon as I bought it using Parallels VM running Windows 7 (I think I almost bricked keyboard while updating but I believe try updating again bought it back).

Now I'm afraid of purchasing any more CM keyboard for Mac as I'm not sure the one I pick will or will not have this problem.

I am currently eyeing MasterKeys Pro S as an replacement for TK but having to spend $130 after already spending $92 isn't easy decision to make.

As for Pro which I'm using as my work place, it's my daily routine to unplug and plug it back in the morning.

And it's not power issue (I already thought about that) as all 3 computers never go to sleep (they're on 24/7).

Pro is connected directly to Mac Pro.

Rapid-i is connected via powered USB 3.0 hub.

TK is connected via powered USB 3.0 hub for each plug/un-plug but was tried connecting directly to iMac 5K and to powered USB 3.0 hub on MBPr.

By the way, my co-worker uses TK on his Dell notebook (he bought it because of me :)) for a few years and he never had any issue which lead me to buy it a few month ago.

 

I really hope there's solution to this problem but it looks like CM isn't interesting in finding solution as Mac isn't officially supported platform.

Share this post


Link to post
Share on other sites

I am having the same issue for linux and I've been trying to fix this issue for about a year now. I have been having difficulty figuring out why this issue is happening. Sometimes this issue happens more often when I cilck a key from one side to the other. Sometimes it happens when I switch to the numpad and back. It happens A LOT when I starting using the backspace. It sometimes happens when I start typing too fast but it also seems to happen even when I'm typing slow.  Sometimes I'll spam the keys super fast and I can start noticing it lag, then other times I'll spam an entire page of letters and it won't lag a bit. 

 

I want to say it mostly happens when pressing space/esc/backspace/forward slashes. Any type of symbol or arrow key or space. There has to be something causing this issue other than it just seemingly being entirely random.

 

I would really like to hear from CM for a potential fix for this as I've spent many hours now researching and testing this issue and trying to find a solution. 

Share this post


Link to post
Share on other sites
Eric    0

I have been seeing the same problem with the Quickfire TK and it continues with macOS Sierra (10.12) and even High Sierra (10.13). I don't know if this is CoolerMaster's issue or Apple's issue, but I would sure love if someone got to the bottom of it and issued a fix. Does CM ever issue firmware updates for keyboards?

 

In any case, I filed a bug report with Apple in September 2016 (bug report 28407366). You can do the same at https://bugreport.apple.com. The more people who report this the better chance they (or CM) will fix it.

 

I have found that the seemingly random disconnection is actually related to the Mac checking for software updates. Here is a test I devised to trigger the problem on my Mac:

 

(1) I opened two windows with the Terminal program. 
(2) In the first Terminal window I type "ls" from the Quickfire TK keyboard to confirm it is working. 
(3) In the first Terminal window I type "softwareupdate -l" to force the Mac to check for updates. 
(4) In the second Terminal window I type "ls" from the Quickfire TK keyboard to see if it is working (it never is at this point). Note that I did not wait for the software update process to complete in the first window. The failure happens immediately (or at least as fast as I can get from one window to the other and type "ls").

 

So give this a try. See if you can replicate the problem. If so, file a bug report with Apple. If anyone knows how to get the attention of CM on this problem, please let us know. 

 

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now