Firmware and Software Error -2 "The System Cannot Find The File Specified"

Recommended Posts

Videshii    0

Hello everyone,


Today, suddenly, my Recon mouse decided to lose it's speed settings and barely move on the desktop. Naturally, I opened and closed the application; all the speed settings were normal. I unplugged and plugged in the mouse again: no good. So I figured I'd just uninstall and reinstall the drivers and software. 


Well, they no longer reinstall. Both the firmware and the software, when I try to install them, give me the error "Error -2: The System Cannot Find The File Specified" and it closes. I've tried it as admin and with various compatibility options: nothing works. Since I was able to install this software just fine originally, and am using *the same* files, why does it suddenly not work? The error doesn't even make sense. The installer can't find it's own file, contained within itself??


Now, I tried reverting to a restore point from yesterday, but then when trying to open the software I get an error saying that the application I'm trying to access requires a network resource that is no longer available. I also can't reinstall in safe mode, because it says the installer service isn't installed. 


I'm running Windows 10 Pro (x64), and it's given me a lot of random grief so far with a lot of software. 


Edited by Videshii

Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.