TheSkilletKing

CM Storm SF-19 Gaming Laptop Cooling Pad with Two 140mm Turbine Fans (SGA-4000-KKNF1) not working as well as it used too.

Recommended Posts

I got a CM Storm SF-19 Gaming Laptop Cooling Pad with Two 140mm Turbine Fans (SGA-4000-KKNF1) two years ago, and it has worked great for me. But recently i have noticed than fans just don't go as fast as they use to, because of this my laptop is getting a little warmer when it used to be nice and cool. So i was wondering if it is something i can fix. Do i need to buy new fans for it? I have used to for at least 1000 hours and possibly am reaching up to 2000 hours, if not already there.

Share this post


Link to post
Share on other sites
knud    123

After 2 years, it is possible you got some dust inside the fans - have you tried to clean them?

Share this post


Link to post
Share on other sites
knud    123

Sounds like the bearings are worn out a bit. Might be time to replace them.

Share this post


Link to post
Share on other sites

Please answer this Question. How is anyone able to change the bearings?

If not, where is it still possible to buy a SF-19 (in Germany)?

 

Greetings

Share this post


Link to post
Share on other sites
Mohd Noh    179
12 hours ago, Ole Kretzschmar said:

Please answer this Question. How is anyone able to change the bearings?

If not, where is it still possible to buy a SF-19 (in Germany)?

 

Greetings

Hi , i would like suggest you contact customer services at here : https://account.coolermaster.com/LogOn.aspx

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now