Recommended Posts

Recentaly built my computer and this happen . I don't know what to do . Everything's is ruined . My computer is sitting at the place I bought the parts from. Everything was new . Watch out guys I wouldn't buy this product never been overclock not even 2 months old

post-104961-0-82035400-1458618704_thumb.jpeg

post-104961-0-88613100-1458618721_thumb.jpeg

post-104961-0-54491900-1458618754_thumb.jpeg

Share this post


Link to post
Share on other sites

There's really no choice but to wipe off (anti static cloth) the big deposits and allow the rest to dry off. If u have a portable heater, low temp and direct it against it for a day (watch it of course).

In parallel, RMA the cooler.

Share this post


Link to post
Share on other sites
Mohd Noh    179

Hi

 

Welcome to CM forum,

 

My suggestion contact CM support services , tell them regarding this issue. maybe they have solution for your question.

Share this post


Link to post
Share on other sites

Hi I own a seidon 240 from November 2014 and I had no problem with it, excluding is a little bit noisy, I agree with Hokage call CM support, that look like a factory defect, mine is cooling a AMD FX 9590 overclocked to 5,017 MHz. Good Luck

Share this post


Link to post
Share on other sites
Mohd Noh    179

Hi I own a seidon 240 from November 2014 and I had no problem with it, excluding is a little bit noisy, I agree with Hokage call CM support, that look like a factory defect, mine is cooling a AMD FX 9590 overclocked to 5,017 MHz. Good Luck

hehehe hokage . :)

 

ya the best way .. is contact CM support services .. tell them regarding this issue.

 

oh man your FX very hot ... 

Share this post


Link to post
Share on other sites

I feel bad for you Taryn, but you either received a one in million kind of defect, or the installer man-handled the piping etc, Reasons do not matter. It leaked and damage is done.

 

What is important for me, is to mention to other readers that I have seen CM liquid coolers in hard use in our home for years now, and I am on my second one personally, never had a single issue. This specific one is in my machine and working like a dream. Please don't discourage or blanket judge it so hard.

 

The clean-up is probably done by now, and I am sure it is not too bad. CM support have been awesome, so I hope you contacted them and found resolution.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now