Katt Kennedy

Quickfire Rapid-i Keyboard Got 99 Problems

Recommended Posts

Hello,

 

I joined the forum because I hear it's the best way to get support from CM, and their customer service is the first I've called that asked me to leave a message (?) rather than putting me through to a rep hahaha

 

I got a Quickfire Rapid-i keyboard for my birthday almost two years back. I have kept this keyboard in a desk with a sliding-drawer compartment to keep debris and dust off of it, used it very gently for a gaming keyboard, and in return it has served me faithfully with high functionality and cool-a-f light patterns.

 

Last night, however, I somehow honked up everything. I was homeless for a while and hadn't used the keyboard in ages. It wasn't until just yesterday that I could finally hook up my rig again in comfort. I had forgotten the key combination to change the light pattern, and genius that I am, I thought I'd just keep guessing rather than look it up.

 

I ended up locking the keyboard into function mode due to holding the FN key down too long in my deliberation. Only issue was, it wouldn't get out of function mode through the method listed in the user guide. Only one key would light at a time, and it had to be F9-F12. All the letter keys were typing crazy duplicates--if I gently tapped "a", I would see "aaaaaaaaaaaaaaaaaaa" appear at about the speed of light.

 

I was able to get the lights working properly again through methods as stupid as those I messed up with (keysmash until victory), but the duplicate key issue persists. I can't find a single result for this problem online. I know the keyboard isn't dirty, it's up-to-date to my knowledge, I have NEVER spilled liquid in it...I don't know how to fix the problem. I can't game or even log in under these conditions! All I wanted was to play Goat Simulator after work sob sob

 

Any help or advice would be very greatly appreciated!

 

Thanks,

 

-Septima

Share this post


Link to post
Share on other sites
CM Bram    35

Hello,

 

I joined the forum because I hear it's the best way to get support from CM, and their customer service is the first I've called that asked me to leave a message (?) rather than putting me through to a rep hahaha

 

I got a Quickfire Rapid-i keyboard for my birthday almost two years back. I have kept this keyboard in a desk with a sliding-drawer compartment to keep debris and dust off of it, used it very gently for a gaming keyboard, and in return it has served me faithfully with high functionality and cool-a-f light patterns.

 

Last night, however, I somehow honked up everything. I was homeless for a while and hadn't used the keyboard in ages. It wasn't until just yesterday that I could finally hook up my rig again in comfort. I had forgotten the key combination to change the light pattern, and genius that I am, I thought I'd just keep guessing rather than look it up.

 

I ended up locking the keyboard into function mode due to holding the FN key down too long in my deliberation. Only issue was, it wouldn't get out of function mode through the method listed in the user guide. Only one key would light at a time, and it had to be F9-F12. All the letter keys were typing crazy duplicates--if I gently tapped "a", I would see "aaaaaaaaaaaaaaaaaaa" appear at about the speed of light.

 

I was able to get the lights working properly again through methods as stupid as those I messed up with (keysmash until victory), but the duplicate key issue persists. I can't find a single result for this problem online. I know the keyboard isn't dirty, it's up-to-date to my knowledge, I have NEVER spilled liquid in it...I don't know how to fix the problem. I can't game or even log in under these conditions! All I wanted was to play Goat Simulator after work sob sob

 

Any help or advice would be very greatly appreciated!

 

Thanks,

 

-Septima

 

For the aaaaaaaaaaaaaaaa inputs it seems you have it locked on a different repeat rate. FN+F8 is 8x, you need to set it to 1x by FN+F5, thanks. 

Share this post


Link to post
Share on other sites
musikman1    0

I'm not sure if others have answered you yet, but I stumbled upon the backlight fix due to "accidental brilliance."

 

I have the quickfile tk, but it's probably the same eprom inside.

 

This worked, but it isn't in the instructions anywhere..

 

FIRST - Hold down the FN key for 3+ seconds until it remains lit (Locked on)

SECOND - Hold down the WINDOWS key.

THIRD - NOW F1 should activate the WASD backlight, F2 will lower light level F3 will raise light level, F4 will allow you to select MODE

 

MODE1 - ALL OFF

MODE2 - ALL ON

MODE3 - USELESS Fade In-Out MODE

 

However, I still haven't figured out how (or if) I can get the LEGENDS to light up..  that would be the !@#$%^&*()-=  keys ROW1,

and [] \ in ROW2, ;' in ROW3 and ,./ in ROW4.  Oh, and ALL of the LEGENDS in the 10 PAD.

 

Cheers!

 

mm1

Share this post


Link to post
Share on other sites
musikman1    0

RE: BACKLIGHTING SNAFU

 

Oh, and according to my manual, it;s supposed to be a RED backlighting, and I've got GREEN.

 

If anyone figures any of these out, drop a note!

 

Cheers!

 

mm1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.