Keir Bourne

Mizar not detected

Recommended Posts

Keir Bourne    0



2 months ago I bought CM Mizar mouse. It set up easily but occasionally would disconnect and only reconnect when I fiddled with the USB port.


However now it is not working at all. I have tried putting the USB cable in every single port, doesn't work. It did turn on at one point, with the scrollwheel lit up but not the logo and I couldn't do anything. Although it had power, buttons did not work and couldn't move the mouse.


Any ideas what to do? I like the mouse don't really want to RMA, but if it has dodgy cable then maybe there is no other option.

Share this post

Link to post
Share on other sites
knud    129

Just to make sure: the mouse works fine on another computer or laptop?

If you get the same result, then you would have to RMA it I'm afraid.

Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.