James Grant

Xornet II won't let PC stay powered off.

Recommended Posts

James Grant    0

With the Xornet II mouse connected to my PC, whenever I power off my PC through Windows within about 5 secs it immediately powers itself back on again.

 

It'll keep doing this until you click the power off button in Windows, then immediately disconnect the Xornet II.

 

I'm using Xornet II firmware 1.02 and application 1.00. I've reset all the Xornet II configuration back to the factory defaults.

 

I'm using a Gigabyte H87N-WIFI motherboard with the latest BIOS (F9). ERP setting in BIOS is enabled (which implicitly disables power on by mouse). This happens on both USB 2.0 and USB 3.0 ports.

 

Has anyone else encountered a problem like this?

 

I've never seen it before with any other mice. Quite an annoying problem.

Share this post


Link to post
Share on other sites
James Grant    0

Seems to have stopped doing it now.

 

Doing a bit more research on this, it seems this *is* actually a thing - some BIOS / chipset quirk.

 

Some Linux kernel developers discuss it here:

 

https://bugzilla.kernel.org/show_bug.cgi?id=66171

 

"xhci: Fix spurious wakeups after S5 on Haswell

 

Haswell LynxPoint and LynxPoint-LP with the recent Intel BIOS show mysterious wakeups after shutdown occasionally."

 

I'm running Windows 10 so don't know what caused it - never seen it with the previous mice I've used.

 

I just know that after many attempts, if you unplugged the mouse it shut down properly.

 

I had previously changed my USB 2.0 ports to explictly be in xHCI mode in the BIOS as well (less CPU usage).

Share this post


Link to post
Share on other sites
James Grant    0

Spoke too soon. Problem is back - so it is intermittent.

 

It doesn't seem to be related to my BIOS USB xHCI settings either (I tried changing them). I think Windows forces it after boot-up somehow anyway.

 

It's definately the Xornet II which is aggravating the problem. Disconnect it, system powers down fine, otherwise you can keep powering down your system all day, and it powers straight back up.

 

Once you disconnect the mouse and successfully shut down, it seems a matter of chance whether you'll have the problem again after re-connect the mouse, then shutting down again.

 

As I said previously, my previous mice never caused this, only Xornet II.

 

lapayo - yeah, i tried changing that setting in device manager, makes no difference.

Share this post


Link to post
Share on other sites
vladimir b.    6

James Grant, you should try to turn off "Fast Startup" ("Control panel" > "Power Options" > "Choose what the power button does" > "Shutdown settings").

It helped me.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.