CM Storm Devastator mouse not working

Recommended Posts

Brovakiin    1

Hi, A few months ago I purchased one of your products of I am now recently experiencing problems with the mouse now. The mice will not move,click, or scroll. The mouse has been working perfect but now is experiencing issues. I am on windows 10 and here is the error code and such:                 

_________________Error Code_________________________________________________________

Windows has stopped this device because it has reported problems. (Code 43)
Unknown USB Device (Device Descriptor Request Failed)
A request for the USB device descriptor failed.
If you can tell me what to do it would be great. 
                                                                                                                     Kindest Regards,
EDIT: All i had to do was plug in the mouse to another computer then re-plug it. I fixed the problem.
  • Upvote 1

Share this post

Link to post
Share on other sites
Pclinde    197

Im have the same problem and dont work replug in another computer


please help

Did you plug it in a USB 2.0 port?

Share this post

Link to post
Share on other sites

Having this problem on Devastator II. First thought it could actually be a problem with the USB port config. since I tried it on a new notebook. Tried everything I saw on the intenet relating this issue, but wasn't able to resolve. Now I opened a ticket to change the product, since it's still on warranty time. Could anyone really solve this?

Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.