3klikguy

CM Storm Mizar double-triple click when lowering button response time

Recommended Posts

3klikguy    0

As title says, when lowering the button response time lower than the 8ms default I experience reproducible double or triple clicks (at least on left click) on about 15-20% of presses. 8ms works just fine.

 

No spills, mouse is one and a half week old.

 

Tried both firmware versions available.

 

Thanks.

Share this post


Link to post
Share on other sites
3klikguy    0

Hi there,

 

To clarify: this does not happen on other button response time settings?

 

Regards,

Bram

 

Doesn't seem to happen on the default 8ms, if I lower to the min or near there it misclicks.

Share this post


Link to post
Share on other sites
Piru Sama    0

I have the same problem, I just bought a Mizar three days ago (february 10th) from a distributor in my country (Peru) and yesterday the mouse started to make double clicks. I have just set button response time to 8m but it doesn't seem to work.

Edited by Piru Sama

Share this post


Link to post
Share on other sites
Pclinde    197

I have the same problem, I just bought a Mizar three days ago (february 10th) from a distributor in my country (Peru) and yesterday the mouse started to make double clicks. I have just set button response time to 8m but it doesn't seem to work.

Can you test this with another computer or laptop? The button / switch might be faulty. + double check your Windows mouse settings. ;)

Share this post


Link to post
Share on other sites
Piru Sama    0

Dear Pim van der Linde, thanks for your response. I tested the mouse on different computers (all using windows 10 by the way, I don't know if that has something to do) and the results were the same. But I can tell you I changed the button response time to 32ms and everything seems to work fine now.

 

When the response time is set to 2ms the double click trouble appears almost 30% of the time I press the left button, when set to 8m the trouble remains but not that often.

 

I will keep testing the mouse.

 

 

Share this post


Link to post
Share on other sites
woll3    0

Dear Pim van der Linde, thanks for your response. I tested the mouse on different computers (all using windows 10 by the way, I don't know if that has something to do) and the results were the same. But I can tell you I changed the button response time to 32ms and everything seems to work fine now.

 

When the response time is set to 2ms the double click trouble appears almost 30% of the time I press the left button, when set to 8m the trouble remains but not that often.

 

I will keep testing the mouse.

 

It works as intended because you reduce the debounce time, if the debounce time is too low then you get double/triple clicks because the switch is still bouncing and therefore signaling 01010101010101.

Share this post


Link to post
Share on other sites
Pclinde    197

Dear Pim van der Linde, thanks for your response. I tested the mouse on different computers (all using windows 10 by the way, I don't know if that has something to do) and the results were the same. But I can tell you I changed the button response time to 32ms and everything seems to work fine now.

 

When the response time is set to 2ms the double click trouble appears almost 30% of the time I press the left button, when set to 8m the trouble remains but not that often.

 

I will keep testing the mouse.

Thanks for sharing your experience! Haven't seen this problem before. :s

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.