Anant C

CM Storm Sirus hub stops working on reboot, needs USB replug

Recommended Posts

Anant C    0

My 1.5 year old Sirus headset/hub was working properly till recently. Now, if I completely power off my system (PSU power), usually for the night, and then turn it on after sometime, the hub doesn't work properly.

 

As soon as system is powered on:

 - The headset powers up (CM logo).

 - The hub mic light comes on.

 - The hub "Master" light comes on.

 - The Volume indicator lights DO NOT come on (they used to until a few days ago).

 

Rotating the volume knob does nothing.

Pressing the center button, for selecting the different channels, does nothing.

 

On entering Windows the headset light on the hub comes on, as it should. The Sirus is detected by Windows. Trying to play any audio, there is an extremely faint sound output by the headset. The volume knob and channel selector still do not work.

 

To fix this I have unplug the USB connectors, wait for a few seconds, and replug them. This causes the volume indicator lights to come on as well and the unit works as it should (knob and center button works). If I unplug the USB connectors and instantly replug them, without waiting for a few seconds, then the prior problem persists. I need to wait 5-10 seconds before replugging (I assume to let the hub capasitors discharge completely).

 

I have tried different USB ports, different USB settings in the bios. Even tried the unit on another system. The behavior is present everywhere.

Share this post


Link to post
Share on other sites
Fulgore    3

hi,

 

i have the headset now almost a year and i have/had this issue also, not windows related, but more a driver - usb port issue, to keep it short

 

check if you are using a usb 3.x or usb 2.0 port, mine was resolved with using a usb 2.0 port, i have not much ports on it and plugged first keyboard and mouse their to be sure that bios, etc works before even windows is installed, but keept me going crazy when headset didnt work, a whole movement to do this, and not fun ive you online with friends and you have to dig first your head behind your pc to fix this....

 

also check your "green" settings like usb suspend settings , the headset need all the time power and by a bug on usb it falls asleep even when connected, this issue is more related to usb 3.0, i had this with windows 8 - 8.1 and intel usb, trying to copy a file around 10 gb or higher took long enough to set the usb in sleep modus, result copy fails...when i did the same on windows 7 the copy did the job.....

 

hopelly you get some info or tips to find out on your specific case, cause every pc is different, as drivers, software and hardware

 

as stated before, since 2 months and daily use i didnt have to unplug the headset......well keep you posted if it happens again

 

but before now on i going back from windows 10 to windows 7 also do the not support in drivers from Coolermaster for our headset....skype and teamspeak dont work if you setup your device in the 5.1 mode

 

Regards

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.