Gezo

CM Storm 5.1 Firmware, Drivers, USB Issue!

Recommended Posts

Gezo    0

Hello. I have been having this problem for some time now. When I first got my CM Storm, it worked fine. I had to use a specific pair of usb ports for it to work, but it would work. Suddenly one day the firmware stopped working. My headset was no longer recognized and I couldnt use it anymore. I uninstalled the Storm Sirus software, and I can use my headphones through windows. But the moment I reinstall the Storm Sirus software, my headset becomes unrecognizable, and Storm Sirus can't find the device. Windows also tries to install some new drivers but that fails. But when I uninstall Storm Sirus, I can use my headset through windows. I dont want to do this as I dont think I am actually getting 5.1 through it. I can only select 7.1 via the speaker setup in  playback devices (and since this is not a true 7.1 headset, rear audio does not work properly). I have been trying other usb ports, and it dosent work. I restarted my PC and oddly my mouse stopped working and I had to use another USB port for that. How can I get the Storm Sirus firmware to actually work again? I really liked it when it worked.

These are images with Storm Sirus installed.

post-100315-0-82545300-1437859741_thumb.png

post-100315-0-40868800-1437859931_thumb.png

Share this post


Link to post
Share on other sites
Fulgore    3

seems more hardware related on your usb ports, if your mouse had same isue, and the headset need two usb connectors...but to be 100 % sure --->

 

try to setup the headset on a friend's pc , than you know its first off all a fresh install of software and driver , than test it out and let us know please

 

so we can help you further

 

regards

Share this post


Link to post
Share on other sites
AndrewTS    0

Hi All, 

 

Perhaps not exactly related to your issue, but I recently got this headset and on two PCs(Laptop Inspiron 15 7537, Older desktop Q9550) and I had the similar error.USB device not recognized etc. and the drivers would not install at all. I did try the usual stuff, updated chipset drivers, BIOS is the latest version already etc etc.

Took it back to the distributor and got it swapped out. The replacement had the exact issue. *Sigh*

I happened to try it on a USB hub I had nearby, as I thought perhaps it might require more power than the laptop USB could provide. (Comment by Fulgore on another post).
Surprise surprise now it works. I can plug the USB hub(with the headset plugged in) in any of my ports on my laptop or desktop and it works every time, hardware is picked up and the sound works.
I tried it on a powered USB hub as well as a non powered hub, and it works off both with no issues. So it wasn't a power issue I don't think
Not sure why the headset USB sound adapter will only work of an external USB hub,  but thought I'd share it, hopefully it helps someone.
 
Cheers
Andrew

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.