UnnamedPerson

LED backlight in CM Storm Quickfire TK not working

Recommended Posts

I was using my keyboard for half a year, and everything was working perfectly fine, until now. When I try to turn the backlight on, keyboard freezes - to make it work, I need to plug it out and in again. Only fn, arrows and numlock + caps lock + scr lock leds are active. I have checked keyboard on other computers - it was the same. USB cable is ok. Anyone had this problem? I don't want to wait so long for RMA...

  • Upvote 1

Share this post


Link to post
Share on other sites
Joost Kolb    0

I have the exact same problem since yesterday... I've made a ticket and hope that Coolermaster will respond soon... this sucks so much I only have this keyboard for around 4 months now...

Share this post


Link to post
Share on other sites

Hi Guys.

 

Same thing just happened to me. In the morning the keyboard was working perfectly fine. Now at night I turned it off and the LEDs are showing the above issue. 

Did you get any feedback from CM? Did anything else work for you?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.