Smeexey

CM Storm Reaper double click problem

Recommended Posts

Smeexey    0

Hello. I encountered a weird problem of double clicking when a normal click is prompted. It occurs every so often and lasts for an hour or so, with no particular pattern. About every 4th click that i make is counted in as a double click with non human speed e.x. opening 2 new chrome tabs with a single click. I have had this problem on my previous mouse which was a logitech g700 and i solved it by readjusting the copper spring inside the switch, this happened after 2-3 years of intense use. I got my reaper about 2 months ago just for the good switches it has and this occurs again after a way shorter period of time. Can i do something about this since i couldnt really find much help online?

Share this post


Link to post
Share on other sites
Pclinde    197

Hi Smeexey,

 

You can modify the double click speed in the Reaper software. Might be worth a try.

 

Cheers, Pim

  • Upvote 1

Share this post


Link to post
Share on other sites
Smeexey    0

Hi Smeexey,

 

You can modify the double click speed in the Reaper software. Might be worth a try.

 

Cheers, Pim

It did nothing. The double clicks that occur are with insane speed, it opens 2 chrome tabs with 1 click which is basically impossible.

Any other ideas on this?

Share this post


Link to post
Share on other sites
Smeexey    0

Hi,

 

Try various USB port, if this doesn't work: request RMA. The Omron switch might be broken.

 

http://coolermaster.force.com/pkb/articles/en_US/FAQ/How-to-obtain-a-product-replacement-RMA/?l=en_US&fs=Search&pn=1

 

Cheers, Pim

I fiddled with the software, it seems like changing the profile fixed it.

I notice it coming back from time to time, but i guess i know the fix now.

 

I suspect it can be a problem with windows regs, cause i havent had this problem on my previous mice before i upgraded to windows 8. Ill just get Win 10 and see if it comes back.

Share this post


Link to post
Share on other sites
3klikguy    0

I described a similar problem with the Mizar here: http://community.coolermaster.com/index.php/topic/14173-cm-storm-mizar-double-triple-click-when-lowering-button-response-time/

 

What I found so far is it occures more, or at all when lowering the "button response time" (default 8ms).

Default profile obviously resets this, maybe that's why it has fixed your problem.

 

Have you modified the response time in the past?

Share this post


Link to post
Share on other sites
Pclinde    197

Modify the double click speed in the software (make sure you use a custom profile).

 

Cheers, Pim

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now