smdb

CM Devastator LED light autostart on Windows - GUIDE

Recommended Posts

zamboni104    0

Aaron, did you ever get this sorted?  I am on Windows 10 as well, has the exact same strange phenomenon of the 6 being re-set to 2, had the same strange long data string in the other registry file, and was able to get the scr lock to work AFTER logging in but not BEFORE.  Not the biggest deal in the world, but I would strongly prefer it to come on BEFORE logging in so I can see the keyboard to type my password.  If anyone has a fix for this, I'd appreciate it!

Share this post


Link to post
Share on other sites
Dude Guyman    1

The gpedit.msc method worked for me on Windows 7 Pro x64. The registry methods failed, same as others.

 

Thanks.

 

If your scroll lock key does not work in Linux (Mint 17.3 and probably most others):

 

Temporary: terminal command
xmodmap -e 'add mod3 = Scroll_Lock'

 

Permanent:
Create .Xmodmap in home directory containing this line:
add mod3 = Scroll_Lock

 

Create /etc/X11/Xmodmap containing the same line:
add mod3 = Scroll_Lock

 

Commands to do it easily. Run the command and paste in: add mod3 = Scroll_Lock

Change "leafpad" to whatever your text editor is (gedit? mousepad?):

 

leafpad ~/.Xmodmap

gksudo leafpad /etc/X11/Xmodmap

Share this post


Link to post
Share on other sites
flake_x    3

Hi all,

to automatically switch on the keyboard's leds on Windows logon, there are several methods:

 

Method 1) Launch setup_Devastator MB24.msi (attached .rar) [working on Win 7-8-8.1-10]: thanks to Breaz

_____________________________________________________________________________________________

Simply decompress the rar file and launch the installer.

 

 

Method 2) Put vbs script in Startup Folder [it seems that isn't working on Win 7 but is OK for Win 10]:

__________________________________________________________________________________________

Put the script in Windows startup folder (hidden folder), your start folder is in ​C:\Users\(account name)\AppData\Roaming\Microsoft\Windows\Start Menu\Programs\Startup

 

[Note: first rename scrlock.txt in scrlock.vbs]

Restart Windows.

 

 

Method 3) Using Group Editor [working fine on Win 10]:

__________________________________________________

Launch Group Editor in Start menu (gpedit.msc), go in USER CONFIGURATION > WINDOWS SETTINGS > SCRIPTS (LOGON / LOGOFF).

Double click on the option LOGON and ADD. There putting the script .vbs (with full path)

 

[Note: first rename scrlock.txt in scrlock.vbs]

Restart Windows.

 

 

Method 4) Using values on Windows Registry:

_________________________________________

You can actually set this string value to any value from 0 – 7 (default is 2), depending on your needs:

    0 – Turn off all keyboard indicators

    1 – Turn on Caps Lock

    2 – Turn on Num Lock

    3 – Turn on Caps Lock and Num Lock

    4 – Turn on Scroll Lock

    5 – Turn on Caps Lock and Scroll Lock

    6 – Turn on Num Lock and Scroll Lock        <-------

    7 – Turn on all keyboard indicators

 

Launch Registry Editor in Start menu (regedit.exe), you can put this value on:

- for all the users on the machine: HKEY_CURRENT_USER\Control Panel\Keyboard\InitialKeyboardIndicators

- for the current user: HKEY_USERS\.DEFAULT\Control Panel\Keyboard\InitialKeyboardIndicators

Restart Windows.

 

 

Method 5) Put the attached script at startup on Windows Registry:

____________________________________________________________

You can start a vbscipt from registry or startup by: WScript C:\somefloder\somefolder2\yourscript.vbs

Launch Registry Editor in Start menu (regedit.exe), you can put this line in a value on:

- for all the users on the machine: HKLOCALMACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Run

- for the current user: HKCURRENTUSER\SOFTWARE\Microsoft\Windows\CurrentVersion\Run

 

[Note: first rename scrlock.txt in scrlock.vbs]

Restart Windows.

 

 

Best regards

SMDB

 

Best regards

Breaz

Edited by Breaz Florin

Share this post


Link to post
Share on other sites
ZakuraTech    0

Sadly none of these methods worked for my Windows 7 prof edition. Extremely irritated that CM made such an error with no apparent fix or way to rebind the key somewher else. It makes using Excel intolerable. I have to work with a bright lamp to even see the keys because they are so dark without the back light. Will probably sell the keyboard and get another one. 
 

Share this post


Link to post
Share on other sites
Jorn Kollen    0

Aaron, did you ever get this sorted?  I am on Windows 10 as well, has the exact same strange phenomenon of the 6 being re-set to 2, had the same strange long data string in the other registry file, and was able to get the scr lock to work AFTER logging in but not BEFORE.  Not the biggest deal in the world, but I would strongly prefer it to come on BEFORE logging in so I can see the keyboard to type my password.  If anyone has a fix for this, I'd appreciate it!

 

I found a post on the microsoft forums where it has a solution to keep numlock on which involves editing all the initialkeyboardindicators registries: http://answers.microsoft.com/en-us/windows/forum/windows_7-hardware/want-to-set-num-lock-to-be-on-and-active-at/7b48ae6f-fa9c-4bc2-8359-81e0c5e5d6a2?auth=1

 

maybe it could work for scroll lock too. Could someone test it?

Share this post


Link to post
Share on other sites
smdb    8

Hi Jorn,

it's the same method reported on 4. I've already reported although for me it didn't work for win 7 and win 10.

 

I put on the list as proposed by microsoft but only for the record... :sad7:

Share this post


Link to post
Share on other sites
Jorn Kollen    0

Hi Jorn,

it's the same method reported on 4. I've already reported although for me it didn't work for win 7 and win 10.

 

I put on the list as proposed by microsoft but only for the record... :sad7:

 

If you look at the solution from the link you will notice their is around 7 registries with InitialkeyboardIndicators which you need to change.

 

I also found 2 other methods here: https://social.msdn.microsoft.com/Forums/windowsdesktop/en-US/559450b8-48ea-44a4-985c-c25b568cd3e1/partially-solved-rewired-keyboard-lol-registry-key-initialkeyboardindicators-never-keeps?forum=windowsgeneraldevelopmentissues

 

The script didn't work for me on win7 Home Premium but it look like it worked for him on Win7 Pro.

 

The other method is in the 2nd post which requires you to re-wire the keyboard so that the light turns on with scroll lock off. I didn't try this method since I don't want to risk breaking the keyboard and needing tools which I don't have.

 

Looks like I will have to upgrade to windows 10 :sad7:

Share this post


Link to post
Share on other sites
azragarn    0

Hi all

 

I like the answers here, and it is great that i now have the lights starting when i log on. My problem is that i use excel quiet heavily so i need Scroll Lock turned off but i need to lights on. I have the devastator II if this makes a difference.

 

I am using Windows 8.1 (work machine)

 

Any assistance would be appreciated. 

Share this post


Link to post
Share on other sites
Romanza313    0

Dear smdbI just want to thank you. You have no idea how much you made my day.

I couldn’t make it Work  ​(none of 3 methods on Windows 10) but I used the script in start folder (hidden of course) and it Works

if anyone else is using Windows 10, your start folder is in ​C:\Users\(account name)\AppData\Roaming\Microsoft\Windows\Start Menu\Programs\Startup

 

now my keyboard is 100% perfect

 

Kind regards

Mik

​

How did you do it? Can you tell me step by step? Did you use the scrlock.txt?

Share this post


Link to post
Share on other sites
smdb    8

Hi Romanza313,

Mr. Mike was using the Method 2 posted in first page of this thread. In any case here below some explainations.

To see the hidden folders in Windows 10 you have to follow the instructions in: http://www.isunshare.com/windows-10/show-hidden-files-and-folders-in-windows-10.html

then you have to rename scrlock.txt in scrlock.vbs (*) and put it in the below path:

C:\Users\(account name)\AppData\Roaming\Microsoft\Windows\Start Menu\Programs\Startup

 

where 'account name' is your windows personal account.

 

(*) to show the file extension follow:

  1. Start Windows Explorer, you can do this by opening up any folder.
  2. Click Organize.
  3. Click Folder and search options.
  4. Click the View tab.
  5. Scroll down until you notice Hide extensions for known file types, un-check this line by clicking the check box.
    Note To hide file name extensions, check this line.
  6. Click OK

 

Everythings is clear?

Edited by smdb

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.