Kousik Biswas

CM Storm Sentinel Advanced, Can't change settings in sofware.

Recommended Posts

Old Mouse, new system. Used to work fine in old system which is gone now. Connected it to my new system (details below), now the mouse works fine but I can't change color settings, acctually I think the software can't access the on-board memory. And in addition the mouse is now showing some auto pointer movements (which of course could be the surface, but I don't think so coz I've tried different surfaces).

 

Current system::

Os = Win 7 64bit

Softaware version = 1.3

Drivers installed (as shown in device manager) = Microsoft HID compatible mouse.

 

 

Any solution / fix?

 

And I've seen this update firmware utilty in the software now. but where do I get the latest sentinel-x firmware? And I how do i get to install the CM drivers replacing the Microsoft generic ones?

 

Any help much apreciated.

Thank you.

Share this post


Link to post
Share on other sites
Pclinde    197

Hi Kousik,

 

Are your USB drivers and BIOS up-to-date? What happens if you run it as an administrator?

 

Cheers, Pim

Share this post


Link to post
Share on other sites

Sorry for the late reply. Been out and busy a little.

 

 


Are your USB drivers and BIOS up-to-date?

USB drivers = yes

BIOS (MOBO) = NO. I'm using one version back. [it's a z97x chipset board]

 

 

 What happens if you run it as an administrator?

 

I alway run cofiguaration/setting changing software in admin mode.

 

 

Anyway, I beleive the issue is due to either the software not recognizing the mouse [but it detects and display the mouse details in the test application] or the the software can't access the firmware on the mouse. But I don't know what might be causing this though.

 

Is there any way to update the firmware on the mouse [sentinel-x]?

Share this post


Link to post
Share on other sites
Pclinde    197

Sorry for the late reply. Been out and busy a little.

 

 

USB drivers = yes

BIOS (MOBO) = NO. I'm using one version back. [it's a z97x chipset board]

 

I alway run cofiguaration/setting changing software in admin mode.

 

 

Anyway, I beleive the issue is due to either the software not recognizing the mouse [but it detects and display the mouse details in the test application] or the the software can't access the firmware on the mouse. But I don't know what might be causing this though.

 

Is there any way to update the firmware on the mouse [sentinel-x]?

The latest downloads are available here: http://gaming.coolermaster.com/en/products/mice/

 

Have you tried another computer or laptop?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.