james griffin

CM Storm MB7C octane keyboard malfunctions

Recommended Posts

So about a week ago I got my CM octane keyboard/mouse combo sent into me and it worked fine at first. Windows (I have 8.1) installed it all fine and I could play games perfectly with the. Then as of yesterday, the keyboard has been making my calculator application pop up randomly, mail app to open, google chrome to open, and search random characters on it (ex: `syp7) and it will sometimes just change the backlight colour without me hitting the button for it. The mouse works perfectly but I have no clue what cause the keyboard to do this. When i connect my old keyboard (eclipse litetouch) back to my computer all the problems go away. I was hoping to reinstall drivers for the MB7C but I can't because its plug and play. And right now I dont do a lot of playing because of this. While I was typing this the calculator app opened and it typed the  "^" character many times. Any help to get this working again is appreciated. 

EDIT* I originally had it plugged into a USB 3.0 but then it started doing problems so I switched it over to the USB 2.0 and now it does it in either USB port

Share this post


Link to post
Share on other sites
world    84

What happens when you connect the keyboard to another computer?

 

If it still has the same issues, I would recommend getting in contact with support so they can point you in the right direction (replacement, etc.)

Share this post


Link to post
Share on other sites

UPDATE ** 

 

While using my keyboard on a friends computer at his house, no problems. On my computer at his house, no problems. The second I connect it at home it goes back to having a bunch of problems. Could it be that I dont have enough power for it or something? 

Share this post


Link to post
Share on other sites
Pclinde    197

UPDATE ** 

 

While using my keyboard on a friends computer at his house, no problems. On my computer at his house, no problems. The second I connect it at home it goes back to having a bunch of problems. Could it be that I dont have enough power for it or something? 

Are you using an Intel or AMD platform?

Share this post


Link to post
Share on other sites
Pclinde    197

Im using an AMD FX™- 8120 eight core

By any chance; is the pc of your friend an Intel PC?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.