jacob maglott

Devastator MS2K Not working

Recommended Posts

I just bought a bundle with the keyboard and mouse 
http://gaming.coolermaster.com/en/products/keyboards/devastator/
and the key baord connected fine but when i plug in the mouse and try to install it, it connects but fails the instalation and tells me something about HID-compatible device. ive tried installing a nuhc of different programs and went through a bunch of different websites and none tell me how to fix this.

Share this post


Link to post
Share on other sites
world    84

Have you tried plugging in your mouse to another USB port or another computer altogether?

Share this post


Link to post
Share on other sites
world    84

Have you tried contacting support? They would probably be the best option since they can help you out with a replacement if needed. Or, you could try getting it replaced by the store you bought if from if you have that option.

Share this post


Link to post
Share on other sites

Is there an update to this problem? I am experiencing the same issue, with the same error on a windows 7 machine. I put the mouse on a different computer running windows 8 and it worked just fine. I have uninstalled and reinstalled twice on the windows 7 machine. There is definitively a driver problem.

Share this post


Link to post
Share on other sites
Teflon    0

I had the same issue. It worked once I:

A) got the key board working. 
B) Unplugged the Mouse.
C) Plugged the mouse back into a different USB Port. 

Hope this helps. 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.