FruitLoop

Quickfire Rapid-i problem

Recommended Posts

Pclinde    197

I bought my keyboard in August and within 2 weeks my first led had died (INS media key). I was annoyed but I thought that seeing as led failure rate is high it was bound to happen to someone. Then a while went by before 2 more led's broke (Backspace and Page Down). At this point I was starting to wonder about RMA as 3 led's down is not only annoying but unacceptable. Now my right side windows led has gone and I am for sure going to RMA this keyboard.

 

Other than this problem though, the Rapid-I is a great keyboard. 

Too bad. We are currently investigating different batches. 

 

Cheers, Pim

Share this post


Link to post
Share on other sites
Pclinde    197

Hello,

The same issue here :( LEDs of 4 keys have died. I bought keyboard in july. Will CM pay for RMA shipping?

Not sure. You can ask them during RMA (make a special note).

Share this post


Link to post
Share on other sites

Looks like there is no reason to make a new thread.

I've just noticed that my '6' is dead. Sad story because I realy like this keyboard.

I will send it back to where I got it so they have to deal with it. :) 

​@Moderator I have two questions

- Was this a problem with other Quickfire keyboards as well? (alternative maybe?)

-How many reports of broken LEDs are there? I really like the keyboard but having dead LEDs all the time is also quite frustrating for a keyboard which costs quite a bit for the small form factor. ;D
 

Share this post


Link to post
Share on other sites
FruitLoop    8

Looks like there is no reason to make a new thread.

I've just noticed that my '6' is dead. Sad story because I realy like this keyboard.

I will send it back to where I got it so they have to deal with it. :) 

​@Moderator I have two questions

- Was this a problem with other Quickfire keyboards as well? (alternative maybe?)

-How many reports of broken LEDs are there? I really like the keyboard but having dead LEDs all the time is also quite frustrating for a keyboard which costs quite a bit for the small form factor. ;D

 

 

From what I've been gathering from other online forums/user posts, this appears to be a problem only with the Quickfire Rapid-i keyboard models.

I'd guess that maybe it has something to do with the way the leds were welded in the switches/backplate (don't know the exact method) or maybe it's the "reactive lightning" modes of the keyboard.

 

The Quickfire TK's don't seem to have nearly has many problems as the Rapid-i does (leds wise).

 

Mine have still just this one dead led on the "E" key, everything else is still lighting fine, so I am really not sure if I should send the keyboard to RMA or not...

I'm a little afraid that more leds die when he comes back. I'm sticking to it by now... but I won't deny that this does bother me a bit.

 

I wish I could replace this Rapid-i with a Quickfire TK with Cherry Mx Blues...

Share this post


Link to post
Share on other sites
lolzman    1

I have tried to return keyboard directly to CM, but then I got message that I have to send it back to the seller. I have bought the keyboard from Amazon, and they allow to return items only during one month after purchase. 

Is there any way to RMA keyboard in this case?

Share this post


Link to post
Share on other sites

Mhh, I don't know what the law says where you live but in germany, I can always send a faulty product back to the seller within the first two years. Obviously, they won't just repair / replace it, when I break stuff but dead LEDs are in most cases production faliurs. 

I think this is european law. We also have a two week time periode where we can withdrawl from the contract, but thats another thing. 

So you should just look what the law says where you live...

Share this post


Link to post
Share on other sites
world    84

I have tried to return keyboard directly to CM, but then I got message that I have to send it back to the seller. I have bought the keyboard from Amazon, and they allow to return items only during one month after purchase. 

Is there any way to RMA keyboard in this case?

 

Is the message from CM support? The best way is to just ask support directly if they can still do an RMA even though they want you to send it to the seller. Since they're handling your case, they'll be the authority for what you can and can't do in the end. 

Share this post


Link to post
Share on other sites
Aris    0

Hi guys,at the end of december 2014 i bought one rapid-i keyboard(my second mechanical-cm storm keyboard after quickfire tk)and today i lost one led(enter's key led).
I spoke with "e-shop.gr",coolermaster's official seller from my country(Greece,Athens) and they ill replace it with a new one this week

Question:Is this problem fixed by coolermaster or the new one keyboard from replacement maybe ill have the same problems?

Share this post


Link to post
Share on other sites

I too, bought my Rapid-i last december. To date, i have RMA'd my keyboard 3 times for faulty LED. Rapid-i either has really bad leds, or i have no luck at all. They should really do something about it.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.